Starting issue need help!!! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 07-19-2009
littlered's Avatar
Thread Starter

iTrader: (2)
I am: Zach Heindselman
Join Date: Sep 2008
Location: Lewistown, Mo
Vehicle: 1998 Ford Ranger
Posts: 1,541
Total Props: 1
Starting issue need help!!!

All morning the truck seemed like it didnt want to start very bad. then i went to get in it to start it and it acted like the battery was dead with the very slow crank. my brother came to jump me and it didnt work. Now it doesnt make any noise when you try to start it. the battery charger says the battery is charged and it is only 3 weeks old. not sure what is wrong. any ideas?
Reply With Quote
+ 0 -
Old 07-19-2009
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
Check both battery cable connections at the battery (clean as needed). Check the positive cable connection at the Power Distribution Box and starter motor, ensuring there clean and tight. Check the ground cable connections at body and engine block, ensuring there clean and tight.

If all the above are good and your sure the battery is charged, try the following:
Turn on headlamps and try starting. Does the headlamps dim or go off during starting?
If they stay bright or only slightly dim, look for starter control problem (Safety switch, starter relay, or solenoid). If they dim or go off, look for problems with the battery, cables, starter relay, solenoid, or starter motor.

2001 Ranger Edge 3.0 V6, 5 speed M/T
Limited Slip Differential, James Duff Traction Bars
Kumho 30x9.50 15 MT / Black 297 Series 15x7 Rims
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
starting issue ranger dad 4.0L OHV & SOHC V6 Tech 5 07-11-2010 05:43 PM
Warm starting issue paddd 4.0L OHV & SOHC V6 Tech 1 03-31-2010 06:00 AM
1983 Ranger starting issue jdubau55 General Technical & Electrical 0 10-06-2009 09:14 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 10:33 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 09:28 PM.