Stuff just stops working!!! - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 06-07-2008
wellcom2knoxvile's Avatar
Thread Starter

iTrader: (2)
I am: Carl Berenson
Join Date: Oct 2007
Location: Corvallis, OR/Seattle, WA
Vehicle: 1996 Ranger 4x4
Posts: 1,390
Total Props: 2
Stuff just stops working!!!

Hey guys

so just randomly got in my truck
turned on and the WINDSHEILD WIPERS DONT WORK!!!
neither does THE RADIO!!!

i dont think it fuses i checkd them all in the little fuse box

what else could it be

they have gone out before but i just replaced the fuse
so i have no idea

driving with no wipers in the rain sucks

1996 4x4 supercab 4.0

thanks for the help
Reply With Quote
+ 0 -
Old 06-07-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
I am: F150 Raptor is just a F150. Calm down kids.
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Vehicle: 2010 Toyota Tacoma
Posts: 7,415
Total Props: 0
Check the fuses carefully. They could have hairline cracks.
Reply With Quote
+ 0 -
Old 06-07-2008
Lord Of War's Avatar
iTrader: (2)
I am: Jake S
Join Date: Jan 2006
Location: Thornton, Colorado
Vehicle: 2002 Ford Ranger
Posts: 4,599
Total Props: 1
Also check the grounds and make sure nothing is wrong with your motor.
Reply With Quote
+ 0 -
Old 06-08-2008
rwenzing's Avatar
RF Veteran
iTrader: (4)
I am: Bob .
Join Date: Nov 2004
Location: Michigan
Vehicle: 2003 Ford Ranger
Drive Type: 4x4
Engine: 5.0
Posts: 7,773
Total Props: 19
Since you have had fuse problems in the past, it would be a good idea to recheck them. If they fail repeated, there is a reason.

Also, take a look at ground G103 which is shared by the wipers and radio and other components. It is under the hood on the driver side inner fender apron about halfway back. You may find broken wires, a loose bolt or corrosion.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering intermittently stops working littlegreen98 General Technical & Electrical 1 10-04-2013 05:11 PM
Want to Buy: Stock CD/Cassette Radio - Working/Partially Working - CA RLong31 Interior, Exterior, Electrical, & Misc. 9 03-18-2011 04:31 PM
For Sale: 2004 Stock Stuff - Lots of stuff... So-CAL RLong31 Interior, Exterior, Electrical, & Misc. 24 04-08-2010 08:20 PM
AC stops working/ temp gauge overheats Dfewer General Technical & Electrical 16 05-23-2008 09:36 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 08:24 AM.