Check engine light wont go off - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-06-2008
MikeyFord3's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: millville, nj
Posts: 79
Check engine light wont go off

well my check engine lights on and i have no clue what it is i checked the oil and its fine the truck its self is running the same as always and not having any problems idk
much about engines im not mechanically inclined so i have no idea waht it could be any ideas
Reply With Quote
  #2  
Old 06-06-2008
MikeyFord3's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: millville, nj
Posts: 79
it came on after a big bump by the way
Reply With Quote
  #3  
Old 06-06-2008
bruiser's Avatar
Member
 
Join Date: Apr 2007
Location: lp,Texas
Posts: 482
go get the codes ran and tell us what they are...auto zone does it for free
Reply With Quote
  #4  
Old 06-06-2008
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
Quote:
Originally Posted by bruiser View Post
go get the codes ran and tell us what they are...auto zone does it for free
x2

if you lived closer i would pull the codes with my scanner.
Reply With Quote
  #5  
Old 06-06-2008
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Quote:
Originally Posted by 5speedin2.3 View Post
x2

if you lived closer i would pull the codes with my scanner.


x3
Reply With Quote
  #6  
Old 06-10-2008
01edgeranger's Avatar
Member
 
Join Date: Jun 2004
Location: Louisville, KY
Posts: 73
Curious to see what you get.
Mine has been on for 2 years now. I did everything that I could and the shop looked at it with no change. I replaced my alternator last year and it went off for about 3 weeks.
Been on ever since. I'm getting Lean Mixture Bank 1 and Bank 2
Reply With Quote
  #7  
Old 06-11-2008
kevinsranger's Avatar
Member
 
Join Date: Feb 2008
Location: jersey
Posts: 388
disconnect the battery for about ten minutes and that should clear it, and if it comes back the worry bout it
Reply With Quote
  #8  
Old 06-11-2008
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
Quote:
Originally Posted by 01edgeranger View Post
Curious to see what you get.
Mine has been on for 2 years now. I did everything that I could and the shop looked at it with no change. I replaced my alternator last year and it went off for about 3 weeks.
Been on ever since. I'm getting Lean Mixture Bank 1 and Bank 2
you have a vacuum leak, check your pcv hose.

thats just retarded that you have been driving it like that for two years.
Reply With Quote
  #9  
Old 06-11-2008
Member
 
Join Date: Apr 2005
Location: ft lauderdale, fl
Posts: 105
Quote:
Originally Posted by 01edgeranger View Post
Curious to see what you get.
Mine has been on for 2 years now. I did everything that I could and the shop looked at it with no change. I replaced my alternator last year and it went off for about 3 weeks.
Been on ever since. I'm getting Lean Mixture Bank 1 and Bank 2
its prob a vac leak, but have you changed the plugs and wires or 02 sensor at all
Reply With Quote
  #10  
Old 06-14-2008
01edgeranger's Avatar
Member
 
Join Date: Jun 2004
Location: Louisville, KY
Posts: 73
Quote:
Originally Posted by 5speedin2.3 View Post
you have a vacuum leak, check your pcv hose.

thats just retarded that you have been driving it like that for two years.
why thank you!

As for the plugs, wires, 02.
Everything. The only thing left to replace is the fuel pump. I've thought about it but never gotten around to it.
I work 80 hours a week at my full time job and at least 20 at my 2 part times.
Fixing a truck is the last of my worries.
Reply With Quote
  #11  
Old 06-14-2008
67cobain94's Avatar
Member
 
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Plugs and wires won't cause a lean code, the computer will compensate for that until it's a misfire. I feel like I say this a whole ton on here about the lean codes being an exhaust leak or a vacuum leak. Also, disconnecting the battery doesn't fix your vehicles, it just delays the inevitable from returning.
Reply With Quote
  #12  
Old 06-14-2008
01edgeranger's Avatar
Member
 
Join Date: Jun 2004
Location: Louisville, KY
Posts: 73
PVC hose? Where is this at?

What type of exhaust leak, cats bad?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Can't Seem to get Check Engine light to Stay Off jonah.m1 General Technical & Electrical 13 11-20-2014 11:23 AM
99 Ranger: engine wont turn over, has power, and no check engine light sprx26 General Technical & Electrical 1 03-19-2014 12:07 PM
problem with engine and check engine light warner.325 SOHC - 2.3L & 2.5L Lima Engines 5 12-09-2009 04:48 AM
spedometer out + ABS light + check engine light joey v General Technical & Electrical 13 06-17-2008 08:17 PM
turning off check engine light panzer 2.9L & 3.0L V6 Tech 9 11-17-2007 09:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.