01 ranger 3.0 2wd has no power and no code? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-04-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: orlando fl
Posts: 3
01 ranger 3.0 2wd has no power and no code?

so i'm trying to help a friend out and his truck has no ***** when taking off or anywhere on up in the power band at all and it will hardly break 70 mph it sounds weird also when it's running kinda hums a bit i thought the cat but there is no code and the check engine light works and is not blocked or covered and not lit up so no c.e.l. .....i was thinking timing? but not sure anyone else have this issue?
it kinda sound like a low hum when he is driving kinda like when your power steering is low but deeper....bare with me here as i'm not a ford guy and trying my best to describe a problem i've not delt with before.


problems that we have fixed before was a melted egr feed back sensor and replaced egr valve tune up air filter and belt tensioner check tranny fluid and it was good and not burnt smelling truck has 126233 on the clock. any help would be great as i'm stumped
Reply With Quote
  #2  
Old 08-04-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: orlando fl
Posts: 3
also bogs down sometimes and will hardly go
Reply With Quote
  #3  
Old 08-27-2011
Member
 
Join Date: May 2010
Location: Twin Cities, MN
Posts: 1
Did you figure it out? I'm having the same problem with my 1999 Ranger 3.0L FFV.
Reply With Quote
  #4  
Old 08-27-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
i had similar problems. my fuel injector harness one cyl 4 was gone and injector on 5 was replaced but advance gave me the wrong one so it was giving my cyl half the fuel it needed. also mechanical damage could cause loss of power. such as burnt valve seats, clogged exhaust, not enough fuel, dirty fuel. bad spark plugs, bad wires, bad coil....
Reply With Quote
  #5  
Old 08-27-2011
Member
 
Join Date: Aug 2011
Location: Pearl River, LA
Posts: 92
Quote:
Originally Posted by basspro717 View Post
also bogs down sometimes and will hardly go
Did you check the EGR ? MAF ? How's it idling? Compression check will tell allot and elminate some key issues.

Sorry, I didn't read the bottom of your first post. EGR good LOL


Cheers,
Gene
Reply With Quote
  #6  
Old 08-28-2011
Member
Thread Starter
 
Join Date: Aug 2011
Location: orlando fl
Posts: 3
ya i figured it out , the cats were clogged. it has 5 of em.
Reply With Quote
  #7  
Old 08-29-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Better find out what caused them to clog.It has other problems.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 Ranger: engine wont turn over, has power, and no check engine light sprx26 General Technical & Electrical 1 03-19-2014 12:07 PM
2000 V6 3.0 Auto ranger... code p0708 has me stumped naudlee Drivetrain Tech 0 07-26-2011 08:27 PM
My old 2wd completely stock and hozII's truck now has his old alcoa's on it Sonic04Edge Snapshots 17 03-04-2011 01:52 AM
Help! Ranger has no power Grizzlybear34 General Ford Ranger Discussion 8 04-18-2007 04:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.