alternator not sending charge to battery - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-14-2015
Member
Thread Starter
 
Join Date: Sep 2015
Location: Los Angeles, California
Posts: 5
alternator not sending charge to battery

I was driving home from work and the battery light came on. i charged the battery but it instantly through the battery light again so i went and bought a new battery and I'm having the same problem. I'm not sure if it's the alternator or if it could be the mega fuse or an inline fuse. I've been trying to find a fuse to replace but um having no luck. Anything would help. It's an '01 XLT 3.0 V6
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery light, No charge off alternator. AK96 General Technical & Electrical 7 11-19-2014 11:27 PM
alt won't charge my battery Mogley General Technical & Electrical 6 01-22-2011 02:52 AM
1996 Battery light coming on, yet battery and alternator work' SariahLeah SOHC - 2.3L & 2.5L Lima Engines 2 06-04-2010 04:16 PM
Battery Charge Question Mykhael General Technical & Electrical 0 06-06-2009 11:52 AM
Battery Light , Alternator bad, truck stalling, wont hold charge ......... pushdeck General Technical & Electrical 5 11-09-2006 12:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:40 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.