Dead Engine - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-25-2006
Member
Thread Starter
 
Join Date: Feb 2006
Location: Kennesaw, GA
Posts: 7
Dead Engine

Hey everyone. I am having a wicked troublesome day. First off I drive an '02 Edge 2WD extended cab. Yesterday evening my truck wouldn't start. I got home from work just fine, but when it was time to leave again...nothing. There are no clicks or attempts to turn over. The interior lights work, then dim when I turn the key to "ON" or when I turn the headlights on. After I turn it off or switch the lights off the brighten up again. Also, once I turn it off and take the key out, the power distribution box starts clicking along with all of my interior and exterior lights blinking. By touch it feels like fuses 46B and 48B found on page #205 here ranger manual pdf. Apparently they control the trailer tow and fog lamps.
I tried jumping it but I got a very rapid clicking that sounded like what I described above. I can't be sure because I was inside the cab at this time. Also I tried replacing the relays with some from my roomate's explorer (same part numbers) but I was working blindly because I don't know what is causing the problem.

Now...today I tried again and am currently working on jumping it again with a set of ears to figure out where the noise is coming from, but after hooking up the cables I walk to the door only to see it locked with the keys on the seat and the spare with my girlfriend who doesn't get home until after dark. Any ideas on the problem and how to get in?
Reply With Quote
  #2  
Old 02-25-2006
92 Ranger's Avatar
Member
 
Join Date: Aug 2004
Location: Raleigh NC
Posts: 1,229
i know that on my rear window its really really easy to get in... just bend a clothing hanger and get it to push the window clip up some and slide the window open, and then use somthing to get the keys... i suppose it could have somthing to do with the starter and stuff.. check all the spark plugs if you havent done so already... also check all the grounds.. and idk lemme think on it
Reply With Quote
  #3  
Old 02-25-2006
Member
Thread Starter
 
Join Date: Feb 2006
Location: Kennesaw, GA
Posts: 7
Mine doesn't have a sliding window, it is just the glass. Just went up to Wal-Mart to try to buy a slim-jim but they don't sell them. It'll probably have to wait for tommorrow anyways when I can get in. Thanks for any ideas you come up with.
Reply With Quote
  #4  
Old 02-25-2006
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
If you can find a gas station around you that a lot of truckrs go to and has alot of truck parts in it there is a chance that you will find a slim jim in there. or call around to car parts stores such as Discount auto, Bennett auto supply. AS for the not starting thing it could be a very dead battery or a bad alternator. just a suggestion. good luck!
Reply With Quote
  #5  
Old 02-25-2006
Member
Thread Starter
 
Join Date: Feb 2006
Location: Kennesaw, GA
Posts: 7
Well I got in. Now I just gotta figure the real problem out.

Last edited by mytmaus; 02-26-2006 at 04:26 PM.
Reply With Quote
  #6  
Old 02-25-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
haha looks like you learned the secret weakness of our trucks. Don't share it please :)

Aaron
Reply With Quote
  #7  
Old 02-25-2006
Rand's Avatar
Member
 
Join Date: Jun 2004
Location: Barberton,Ohio
Posts: 1,189
Clicking and not turning over means dead battery.
Reply With Quote
  #8  
Old 02-26-2006
Member
 
Join Date: Dec 2005
Location: Crestview, FL
Posts: 46
Clicking and not turning over does not mean dead battery. Had that problem with my other truck, and the problem ended up being a bad ground connection. But if I read the original post right thats not the problem, but I'm kind of drunk right now, so I might have missed something important.
Reply With Quote
  #9  
Old 02-26-2006
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
could you guys delete post #5 and #6 we dont need talk like this on a public forum thanks guys
Reply With Quote
  #10  
Old 02-26-2006
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
Nowhere in this thread is it saying how to do the magic door pop. You can disassemble any automobile's door from the inside and make it unlock.

That said, as a general rule, please do not get any mor detailed about how to break into our vehicles on a public forum. Thanks!
Reply With Quote
  #11  
Old 02-26-2006
Member
Thread Starter
 
Join Date: Feb 2006
Location: Kennesaw, GA
Posts: 7
As of now, I went took off the starter and alternator to get them tested. The starter checked out but the alternator was charging at 10 Volts. I replaced the alternator and it started doing the same thing. After a few tries of jumping it I got it cranked but tested my luck too far by driving around a bit and killing it to try again. Now it will click rapidly, and maybe turn over once but won't start again. I guess it's time to give in and tow it before I spend a fortune attempting fixes on stuff that isn't broken.
Reply With Quote
  #12  
Old 02-26-2006
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
If the alternator was charging at 10 volts, you battery is toast. Replace it and I bet all will be well.
Reply With Quote
  #13  
Old 02-27-2006
Member
Thread Starter
 
Join Date: Feb 2006
Location: Kennesaw, GA
Posts: 7
We got it started again by sheer luck. We tried a different battery, although not brand new, and got the same results. After it started the speedometer started jumping around between 15-20 mph while in park. With those kind of electrical issues I took it straight to the dealer before I pressed it any further. We'll see what they say later today I guess. Thanks everyone, but it looks like this round goes to the truck. Truck-1...Me-0.
Reply With Quote
  #14  
Old 02-28-2006
Member
 
Join Date: Dec 2005
Location: Crestview, FL
Posts: 46
Sorry to hear that, never nice to see man lose to the beast.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Flasher Relay? Flashers are dead.. help rngprerunner General Ford Ranger Discussion 15 07-04-2007 07:01 PM
How do I replace dead LED's in cruise control pod? Glowin3232 General Technical & Electrical 1 06-07-2005 02:14 PM
dash electronics dead...poppin fuses Alon General Technical & Electrical 11 05-15-2005 05:40 PM
Night from hell.....Truck dead *long story* FLPanther General Ford Ranger Discussion 12 03-14-2005 06:41 PM
truck dead?????? BananaEdge General Technical & Electrical 3 02-07-2005 12:46 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.