Help Ranger Misses - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-17-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Memphis,In
Posts: 1
Help Ranger Misses

I have a '99 Ranger 3.0 flex fuelthat runs fine cold...when it gets warm it starts missing on the right bank..Cyls 1, 2 & 3...I have replaced the plugs, coil pack, wires , checked compression. all cyls have 130-140psi..I have put a new O2 sensor in the right side, cleaned the mass air flow sensor and the cold air sensor in the intake tube...Can anyone help
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
93 Ranger 2.3 misses under load at take off and mid throttle 93rangerbamaboy SOHC - 2.3L & 2.5L Lima Engines 1 01-15-2014 05:37 PM
My turn with the misses Puddinhead 2.9L & 3.0L V6 Tech 24 04-23-2011 07:32 AM
when it snows it misses!!! jrex General Technical & Electrical 5 12-10-2010 07:57 PM
96 Ranger Stalls and Misses when Accelerating and Low RPM's acleme1 2.9L & 3.0L V6 Tech 1 10-03-2008 07:32 AM
Misses letting off of throttle ckbwv SOHC - 2.3L & 2.5L Lima Engines 0 03-30-2008 07:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.