misfire at start up when topping off coolant - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-25-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: lyons michigan
Posts: 2
misfire at start up when topping off coolant

I have a 98 ranger with a 3.0 that ticks on start up when ever i add coolant. by the way the engine is a rebuild so i don,t think its a head problem. I really just want somebody to confirm my suspicion that its probably the intake manifold before i tear into it again. or tell me i.m dumb and it cant be that as long as i figure out what he problem is!
i have been losing coolant and the tick goes away once the coolant falls below a certain level.

Last edited by the bone; 06-25-2010 at 02:28 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 05:27 PM
Antifreeze/Coolant evaporating/burning off? Hawklore 4.0L OHV & SOHC V6 Tech 4 12-28-2009 01:21 AM
Serious coolant leak...Only when It's off t0x1k 2.9L & 3.0L V6 Tech 3 03-09-2009 11:26 AM
topping out T-Bars Flyinfx4 Suspension Tech 8 07-07-2005 10:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.