Need some advice please. Engine jumping at 3k to 4k rpms. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-30-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
Need some advice please. Engine jumping at 3k to 4k rpms.

Ok i have an 02 ranger edge, v6 3.0l. here lately its been acting funny at around 3k-4k rpms, mainly when im on the highway and need to floor it to get around someone. It feels like it is jumping, when i had drew(edgeman4.0) help me tune it this weekend he said he thought it was misfiring. So i took it advance auto to have them pull the codes to see what it said, the computer wasnt throwing any codes out. I have had people tell me it could be the fuel filter, which we tried to change over the weekend but the clips broke; have been told could be vacuum leak, spark plugs which were changed along with the wires, coil pack. Anybody have any advice as to what they think that it might be? any advice will be greatly appriciated.
Reply With Quote
  #2  
Old 03-30-2009
fordktrucks's Avatar
Member
 
Join Date: Mar 2009
Location: clyde, nc
Posts: 8
it really sounds like the fuel filter but you probably have more than just the one my 86 has three
Reply With Quote
  #3  
Old 03-30-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
three what? filters, wow! ive only seen on on my truck
Reply With Quote
  #4  
Old 03-30-2009
fordktrucks's Avatar
Member
 
Join Date: Mar 2009
Location: clyde, nc
Posts: 8
yeah i got one right behind the motor one on the frame and one in the tank but your problem sounds just like the one i had and i ended up changin all three of mine but they had been on there 20yrs
Reply With Quote
  #5  
Old 03-30-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
yeah, i have the new filter already, was trying to change it over the weekend, but the clips that hold it in broke and we couldnt get the lines off, it was saturday so the ford place wasnt open, drew(edgeman4.0) is going to get the clips today, havnt talked to him yet on when he'll be able to chane the filters
Reply With Quote
  #6  
Old 03-30-2009
fordktrucks's Avatar
Member
 
Join Date: Mar 2009
Location: clyde, nc
Posts: 8
they make speical tools to take those lines off
Reply With Quote
  #7  
Old 03-30-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
yeah ive read on different palces about them, some are plastic and arnt worth it, drew(edgeman4.0) thought he could get it off without the specail tools
Reply With Quote
  #8  
Old 03-30-2009
Step Over the Edge's Avatar
Member
 
Join Date: Dec 2007
Location: Albuquerque, NM
Posts: 324
I've changed my fuel filter on the frame rail multiple times without any special tools and never broken the clips. Just pliers, and even got them off with my fingers one time, just fyi. As long as you know the clips dont come out, they depress in...
Reply With Quote
  #9  
Old 03-30-2009
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
Your symptoms sound like a bad camshaft position sensor.
Reply With Quote
  #10  
Old 03-30-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
hmmm havent haerd that one yet, i have had it die on me when i come to a stop a couple of times, but that hasnt happened any recently
Reply With Quote
  #11  
Old 04-01-2009
Member
 
Join Date: May 2005
Location: .
Posts: 87
i think my truck is doing the same thing check engine came on once and i pulled the code it read "misfire in cylinder 3" i changed the plugs and wires, have ran numerous fuel injector cleaner through it for the past month and it is still doing it to me, its driving me nuts. i have also heard that i might have water in my gas tank...i have not checked that yet but i am willing try anything now
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1984 ranger 2.0 need some advice please maxima2fst4u SOHC - 2.3L & 2.5L Lima Engines 2 03-19-2012 11:14 PM
Rough idle and engine stalls at high rpms. evadfa General Ford Ranger Discussion 1 10-24-2011 07:00 AM
Ranger 1998 V6 3.0L jumping idle and stopping engine cegascon 2.9L & 3.0L V6 Tech 2 04-24-2011 01:56 PM
Engine high rpms with ac on 98greenranger General Technical & Electrical 0 07-11-2010 09:38 PM
Engine rpms drop and then rev up to normal shrimpfisherman General Technical & Electrical 2 10-29-2007 10:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.