Over drive button problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-27-2008
Member
Thread Starter
 
Join Date: Oct 2008
Location: SI,NY,NJ
Posts: 3
Over drive button problem

Hello,

I have a 99 4wd 3.0 with a automatic trans,The Overdrive on/off switch on the gear selector doesnt work.
Is there away of manually turning it on and off ?
I looked in the owners manual for a fuse but nothing was specific about the od button.

Any help will be much Appreciated thanks,Mike
Reply With Quote
  #2  
Old 11-27-2008
Member
 
Join Date: Nov 2008
Location: Hardin, IL
Posts: 28
I'm having the same problem. Only mine is a 02 with a 4.0. It was working for a while then it quit. Seems like the same time it quit the lights in my cruise buttons went out.
Reply With Quote
  #3  
Old 11-27-2008
Member
Thread Starter
 
Join Date: Oct 2008
Location: SI,NY,NJ
Posts: 3
Becker your problem seams like it might be a fuse because the cruise lights shut off too.
My cruise control still works,just the button doesnt click.
Reply With Quote
  #4  
Old 11-28-2008
Member
 
Join Date: Nov 2008
Location: Hardin, IL
Posts: 28
Yeah my cruise works too, just the lights don't come on... Not a big deal really. But the OD button deal could actually be an issue some day.
Reply With Quote
  #5  
Old 11-28-2008
Slevin's Avatar
Member
 
Join Date: Nov 2008
Location: san jose, ca
Posts: 24
Ford has an issue with the OD button wiring rubbing on the steering column. If you take the upper column off you should be able to see if the wiring has been grounding out. Im sure you have to take the ignition tumbler out.
Reply With Quote
  #6  
Old 11-28-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
It shouldn't be necessary to pull the ignition lock. Just remove the upper plastic trim and inspect the two wires where they come out of the hollow shifter stalk. One or both are probably broken or grounding. The fuse is #27 for the 1999 and fuse #2 for the 2002.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Only one horn button works..anybody else have this problem ? surfrat1 General Technical & Electrical 0 06-23-2015 08:48 PM
Over Drive Button Help atrocity General Ford Ranger Discussion 7 09-07-2012 07:41 PM
Over drive problem Mark43 Drivetrain Tech 0 03-06-2008 11:43 AM
Turns over and over and over before starting strictlystangs2 SOHC - 2.3L & 2.5L Lima Engines 7 11-21-2007 10:54 PM
O/D Button problem bucky919 General Technical & Electrical 7 09-17-2007 10:57 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.