Problems at Starting..... - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-21-2009
Member
Thread Starter
 
Join Date: May 2009
Location: Fernie. BC
Posts: 2
Problems at Starting.....

Hey guys...I got this little problem that happens once in a while...after driving my truck for a while.....when I stop for a while and want to restart, the engine turns but just doesnt want to fire up I usually wait 20 minutes and then it starts but only after a few tries......it starts good every morning though ....I've ran a scan and no codes are showing up......so I was wondering if anyone had that problem before on a 95 ranger 3L...thanx in advance JF
Reply With Quote
  #2  
Old 05-21-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
sounds to me like the fuel pressure is leaking down over time causeing it not to start. i want to say check the pressure reg but im not even sure thats it.
Reply With Quote
  #3  
Old 05-22-2009
RedRanger91XLT's Avatar
Member
 
Join Date: May 2009
Location: Woodbridge, VA
Posts: 316
Did you do both KOEO and KOER tests?
Reply With Quote
  #4  
Old 05-22-2009
Member
Thread Starter
 
Join Date: May 2009
Location: Fernie. BC
Posts: 2
Yeah and nothing came on.......My friend is going to bring his gauge from work to check the fuel pressure tonight so I'll know a little more about that in a bit.....
Reply With Quote
  #5  
Old 05-22-2009
RedRanger91XLT's Avatar
Member
 
Join Date: May 2009
Location: Woodbridge, VA
Posts: 316
Quote:
Originally Posted by jfturpin24 View Post
Yeah and nothing came on.......My friend is going to bring his gauge from work to check the fuel pressure tonight so I'll know a little more about that in a bit.....
Sometimes the check engine light blinks, but won't show up on the code reader. I assume you know how to read a blinking check engine light.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starting Problems patkelly1336 4.0L OHV & SOHC V6 Tech 0 04-06-2011 05:57 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
Starting problems...HELP!! rangererv 4.0L OHV & SOHC V6 Tech 9 08-04-2005 01:01 PM
Starting problems Just Plain Dave General Technical & Electrical 6 07-10-2005 08:43 PM
problems starting up ihatefords2 DOHC - 2.3L Duratec / Mazda L Engines 6 06-01-2005 09:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:49 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.