Revs up upon pressing in clutch - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-12-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: Oakville, Ontario
Posts: 20
Revs up upon pressing in clutch

As the title states, my truck will rev up about 250 rpm or so when i kick in the clutch. I didn't notice it when I test drove the truck, and had thought I was leaving my foot on the gas pedal when i kicked in the clutch, but i've come to the obvious conclusion, that it can't be me. lol

This only happens when I'm rolling, and I don't always notice it, but it's there. I haven't noticed any particular speeds it happens around, or any serious contributing factors.

I'm going to try cleaning out the throttle body this weekend, and see what's up.
Reply With Quote
  #2  
Old 10-12-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Just clean the IAC as that is most common.
Reply With Quote
  #3  
Old 11-22-2011
myersth's Avatar
Member
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
my 98 did this. i would take it out of gear or kick the clutch in and it would rev up to like 4 grand and wouldnt stop till i put it back in gear or shut the truck of and turned it back on. it only did it few times so idk if it is fixed or not
Reply With Quote
  #4  
Old 11-23-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: Oakville, Ontario
Posts: 20
thankfully, it is not that severe, my father is under the impression that it's like that to help with downshifting...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine revs when clutch is pushed in JASONGR81 General Technical & Electrical 16 08-04-2016 05:38 PM
Pressing in ball joints the right way k.blakeley General Ford Ranger Discussion 7 04-10-2014 06:32 PM
Any tips on pressing out ball joints and control arm bushings dmcs14 General Technical & Electrical 14 02-07-2012 11:00 AM
A/C Doesn't work when pressing the Gas NedoMedo 2.9L & 3.0L V6 Tech 3 07-20-2010 08:31 PM
Puff of smoke upon start-up weaveredge 2.9L & 3.0L V6 Tech 24 09-25-2005 10:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.