Rough Idle - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-24-2008
Frank91's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: maryville
Posts: 61
Rough Idle

I changed the spark plugs and a few days later it started to have a rough idle and studder a little bit,when it gets over 1500 rpms its fine.


I also put a Thrush glasspack in place of the old muffler.Would that affect anything?

any suggestions?
Reply With Quote
  #2  
Old 11-24-2008
lifted_Mazda01's Avatar
Member
 
Join Date: Aug 2008
Location: Davie, FLA
Posts: 685
change out your coil pack, that was my issue
Reply With Quote
  #3  
Old 11-25-2008
Prerunner-Ranger's Avatar
Level I Supporter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Check ur wires.
Reply With Quote
  #4  
Old 11-25-2008
htjunkie's Avatar
Member
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
What plugs did you go with?
Reply With Quote
  #5  
Old 11-25-2008
Frank91's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: maryville
Posts: 61
I put in Motorcraft Platinum ,but i did not change the wires.
Reply With Quote
  #6  
Old 11-26-2008
htjunkie's Avatar
Member
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
Reason I'm askingm is cause I went to a "better" plug, and my truck ran like crap. Went back to the original plugs, and it was back to normal.
Reply With Quote
  #7  
Old 11-26-2008
Member
 
Join Date: Jul 2008
Location: buffalo, ny
Posts: 14
do this bro.... put your truck in a garage with the lights off. pop the hood, start the engine, and watch for a little blue arc under the hood anywhere near any of the ignition wires/hardware. if you see an arc near a wire, change out the wires, otherwise, if you see nothing, do the coil pack.
Reply With Quote
  #8  
Old 12-19-2008
dngerzone's Avatar
Member
 
Join Date: Sep 2007
Location: Tacoma, Washington
Posts: 342
try sea foam...
Reply With Quote
  #9  
Old 12-20-2008
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
Change your plug wires. They are easily damaged when you pull them off your old plugs.
Reply With Quote
  #10  
Old 12-20-2008
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
Quote:
Originally Posted by shybriguy View Post
do this bro.... put your truck in a garage with the lights off. pop the hood, start the engine, and watch for a little blue arc under the hood anywhere near any of the ignition wires/hardware. if you see an arc near a wire, change out the wires, otherwise, if you see nothing, do the coil pack.
This is true if the insulation is breaking down, but the core conductor can be broken, and you won't see an arc.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
M5OD rough shift on rough roads, potholes, speed bumps Mike_92 Drivetrain Tech 0 10-28-2013 10:26 PM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM
Rough idle, check engine light SnowGoAK 4.0L OHV & SOHC V6 Tech 6 06-24-2005 04:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.