Running Rich - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-04-2011
Member
Thread Starter
 
Join Date: May 2011
Location: san diego ca
Posts: 6
Running Rich

gotaford 2000 ranger running rich on left bank got a black tailpipe and code default for left bank running rich .I can cut the check engine light by disconnecting battery and drive all day with light out and as soon as I turn it off.. then restart the light comes back on. could it be the o2 sensor giving the computer false read or maybe the MAS ? any ideas or thoughts?
Reply With Quote
  #2  
Old 06-05-2011
acemavrick's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: ky
Posts: 663
get the code im gonna say 02 but since ur down there id replace both cause u know murphys law...
Reply With Quote
  #3  
Old 07-12-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
I know its an old thread but I don't wanna make a new one to ask the same question. I just replaced my egr valve and tube and now I'm running rich. Any ideas on what is causing this?
Reply With Quote
  #4  
Old 07-12-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Quote:
Originally Posted by hurley View Post
I know its an old thread but I don't wanna make a new one to ask the same question. I just replaced my egr valve and tube and now I'm running rich. Any ideas on what is causing this?
Post the PCM codes.
How do you know it's running rich ?
Reply With Quote
  #5  
Old 07-12-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
I got my check engine light checked and came up with three codes. I have them written down at home. I'll post them in an hour or two.
Reply With Quote
  #6  
Old 07-12-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
P0402 The ECM has detected too much flow on the EGR system
P0171 Fuel bank one condition
P0174 Fuel bank two condition
Reply With Quote
  #7  
Old 07-14-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
help? i think it might be my O2 sensors but i could use a second opinion.
Reply With Quote
  #8  
Old 07-14-2011
acemavrick's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: ky
Posts: 663
make sure y didnt put ur EGR on backwards i know it sounds dumb but i see it all the time at work lol and make sure all ur lines are hooked up and u didnt miss one
Reply With Quote
  #9  
Old 07-14-2011
hurley's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2010
Location: West Belmar NJ
Posts: 1,488
How do you put it on backwards? There is only one way to put it on and the only lines that connect to it are the egr tube which is tight and the rubber hose on the top.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP!! 87 Ranger running too rich. HELP!!!!!!! Snow Wolf SOHC - 2.3L & 2.5L Lima Engines 20 09-04-2007 10:44 AM
Running rich, codes p1131 p1132 flyinhawaiian SOHC - 2.3L & 2.5L Lima Engines 0 12-13-2006 09:59 PM
Running rich? 90Ranger2x4 SOHC - 2.3L & 2.5L Lima Engines 11 11-19-2006 03:32 PM
engine stalling/running rich ranger024x4 4.0L OHV & SOHC V6 Tech 9 02-09-2006 05:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:32 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.