seems to miss fire - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-02-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
seems to miss fire

alright did plugs last night and changed the battery, and pluged in a wire harness that goes to the condenser that was for some reason unplugged for a long time. now i believe it miss fires, it ran fine for like 5 seconds this morning then it started carrying on again, has like no power, and is obviously really roughreally shakes the thing when idleing, just for ****s and giggles i unplugged the MAS with no change i also cleaned that with brake parts cleaner, it sat for hours before i put it in, any help would be appreiciated
Reply With Quote
  #2  
Old 05-02-2011
99 RANGER's Avatar
Member
 
Join Date: Jul 2008
Location: Hamburg
Posts: 24
Sounds like the plug wires are out of order....
Reply With Quote
  #3  
Old 05-03-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
i've been switching the around with now luck the only two i messed up with i tried to switch and it got worse, that's what i though at first too
Reply With Quote
  #4  
Old 05-04-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
new distributor cap and rotor after new plugs and wires, old cap was worn out like you wouldn't believe, runs on all six cylinders now idles high but that's an issue for anotoher day
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 4.0 has a weird miss fire Dutter 4.0L OHV & SOHC V6 Tech 8 12-27-2011 07:42 PM
3.0L Miss fire and running lean n Bank #2 marc83 2.9L & 3.0L V6 Tech 2 03-25-2011 05:50 AM
This is a very detailed description of whats goin on...a miss-fire!!! sam0330 2.9L & 3.0L V6 Tech 4 12-21-2009 04:31 PM
Miss fire cylinder 2 marc83 General Technical & Electrical 4 10-20-2009 07:20 PM
Engine seems to miss ? crazy wheelerman 730 2.9L & 3.0L V6 Tech 3 02-26-2006 09:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:01 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.