Won't stay running. HELP! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Won't stay running. HELP!

2006 3.0...Drove to work in the morning and she ran fine. I went to leave and go home and it had a rough Idle so I pulled around our shop to our mechanic to let him check it out. Before he came out it died and since then it will start up and idle for less than 5 seconds. Had a friend come over and today to see if it had any codes to pull but there wasn't any. Anyone have or had this problem or know how to fix it?
Reply With Quote
  #2  
Old 10-01-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Does the oil pressure gauge show pressure when it runs in that 5 seconds ?
Reply With Quote
  #3  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by OTRtech View Post
Does the oil pressure gauge show pressure when it runs in that 5 seconds ?
I don't know I don't have one. I have a Tach, oil Temp, fuel, and speed
Reply With Quote
  #4  
Old 10-01-2009
FoMoCoFiddy's Avatar
Member
 
Join Date: May 2004
Location: Smackdownville Tx
Posts: 4,508
Alternator?
Reply With Quote
  #5  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by FoMoCoFiddy View Post
Alternator?
Idk I don't think so. Ever heard of that causing the same problem. It starts and idles and then something is shutting down the fuel. Misted gas in the breather and kept it running. My buddy said he thought it might be the key or the alarm but I talked to ford and they said if the light for the alarm goes off when the key is on then its not the alarm. Light goes off when key is on. He said the key or a Pat(sounded like what he said)
Reply With Quote
  #6  
Old 10-01-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Check the fuel cut-off switch under the dash by the passenger footwell .
Reply With Quote
  #7  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by OTRtech View Post
Check the fuel cut-off switch under the dash by the passenger footwell .
what should I be looking for?
Reply With Quote
  #8  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
I found it what do I check for?
Reply With Quote
  #9  
Old 10-01-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Quote:
Originally Posted by blueranger06 View Post
what should I be looking for?
Your owners manual . It shows where it is .
Reply With Quote
  #10  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
I know where it is but how do I know if there is problem with it?
Reply With Quote
  #11  
Old 10-01-2009
paintballer4758's Avatar
Member
 
Join Date: Aug 2009
Location: Renton, WA
Posts: 235
there is a button on it and you can push it to reset it... (or at least thats how it is in my friends 04 edge)
Reply With Quote
  #12  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Fuel pump comes on if that is any help?
Reply With Quote
  #13  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Ya I was pushing a few times and still the same problem. I looked it up and it shuts off the power to the fuel pump but my fuel pump is working. I think it was 60 psi.
Reply With Quote
  #14  
Old 10-01-2009
paintballer4758's Avatar
Member
 
Join Date: Aug 2009
Location: Renton, WA
Posts: 235
hmm thats weird... and you dont have a check engine light on or anything?
Reply With Quote
  #15  
Old 10-01-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
get gas recently ?
Reply With Quote
  #16  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by paintballer4758 View Post
hmm thats weird... and you dont have a check engine light on or anything?
Nope. Lights clear when it starts to idle then it just dies like something shut the fuel off.
Reply With Quote
  #17  
Old 10-01-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by OTRtech View Post
get gas recently ?
Ya I got gas the day before.
Reply With Quote
  #18  
Old 10-01-2009
Member
 
Join Date: Aug 2009
Location: Milac, GA
Posts: 48
Will it stay running if you give it gas, or still die regardless?

If you have a second ignition key, try that one.......
Reply With Quote
  #19  
Old 10-02-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by Runnin'OnEmpty View Post
Will it stay running if you give it gas, or still die regardless?

If you have a second ignition key, try that one.......
I know a guy who could come out and check it with a computer and make a key for like $80-100. I lost my original key. It will rev up at least twice and then shuts off.
Reply With Quote
  #20  
Old 10-02-2009
Demo1986's Avatar
Member
 
Join Date: Feb 2009
Location: Long Beach, CA
Posts: 423
Sounds like there's a leak chk ur pcv elbow. My truck had the same issue and I had a hole on the elbow
Reply With Quote
  #21  
Old 10-02-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Ok I'm gonna go out and check it
Reply With Quote
  #22  
Old 10-02-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
It's the hose on the back side of the intake?
Reply With Quote
  #23  
Old 10-02-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Should be on the back of the valve cover if i remember correctly.
Reply With Quote
  #24  
Old 10-02-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Seems to be okay. How big would the hole have to be to cause a problem. Also I was told that it would be hard to crank if there was hole. I have no problem starting but something is shutting down the fuel.
Reply With Quote
  #25  
Old 10-02-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
It was a relay I guess. I switched 46A with 46B and she's running. Still doesn't idle perfectly at times but stays running but when I start to drive it shuts off. At an idle she revs and idles but cuts out when I release the clutch and drive.

Last edited by blueranger06; 10-02-2009 at 05:34 PM. Reason: change
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Motor will only stay running for a few seconds when it does start, please help if can Joe Green SOHC - 2.3L & 2.5L Lima Engines 2 11-29-2011 10:11 PM
Starts but won't stay running xxATMORExx 4.0L OHV & SOHC V6 Tech 7 09-20-2011 08:37 AM
Please HELP! will not stay running!!!! due to column problems 99Stranger General Ford Ranger Discussion 1 09-14-2011 09:15 PM
truck won't stay running Mogley 2.9L & 3.0L V6 Tech 11 12-12-2010 01:10 PM
Truck won't stay running blissintampa SOHC - 2.3L & 2.5L Lima Engines 5 04-26-2008 03:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.