Won't stay running. HELP! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 10-02-2009
mitchell561's Avatar
Member
 
Join Date: Sep 2008
Location: wellington,fl
Posts: 191
same problem happen to me it sounds like your mass flow sensor is bad
Reply With Quote
  #27  
Old 10-03-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
I'll have to check it thanks.
Reply With Quote
  #28  
Old 10-03-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
It would be great if I could find another ranger near by to borrow his mafs before I spend $210
Reply With Quote
  #29  
Old 10-03-2009
BettyVo7Ranger's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
on my bros 04 the wires on the bottom of the fuel cut off where messed up we had to play with them for a bit....thats what it sounds like to me
Reply With Quote
  #30  
Old 10-03-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
That is to shut off the fuel pump..did his fuel pump not work.
Reply With Quote
  #31  
Old 10-03-2009
btm757's Avatar
Member
iTrader: (5)
 
Join Date: Jun 2009
Location: Norfolk / Chesapeake, VA
Posts: 3,980
Actually the button resets the fuel pump in a sudden jar (crash or hard bump) the fuel pump shuts off and the button resets it.

Also check throttle position sensor, maybe cam sensor. my moms 3.0 Taurus runs rough sometimes and will cut off and its the cam sensor. Also crank sensor could be checked as well not sure if it would start at all if it was the crank sensor
Reply With Quote
  #32  
Old 10-03-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by btm757 View Post
Actually the button resets the fuel pump in a sudden jar (crash or hard bump) the fuel pump shuts off and the button resets it.

Also check throttle position sensor, maybe cam sensor. my moms 3.0 Taurus runs rough sometimes and will cut off and its the cam sensor. Also crank sensor could be checked as well not sure if it would start at all if it was the crank sensor
Thanks. I bought some mafs cleaner and see if it works. I saw online there is some way to check it. I can get a new mafs from auto zone for 119 (referb) so that is better than $209. After that I plan on checking the TPS I guess.
Reply With Quote
  #33  
Old 10-03-2009
btm757's Avatar
Member
iTrader: (5)
 
Join Date: Jun 2009
Location: Norfolk / Chesapeake, VA
Posts: 3,980
I didnt realize the mafs cost that much. dern
Reply With Quote
  #34  
Old 10-03-2009
Demo1986's Avatar
Member
 
Join Date: Feb 2009
Location: Long Beach, CA
Posts: 423
The pcv I changed was in front of the tb just below ur radiator hose
Reply With Quote
  #35  
Old 10-04-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by btm757 View Post
I didnt realize the mafs cost that much. dern
Ya me either until I priced them. Its kinda setup to fail eventually IMO.
Reply With Quote
  #36  
Old 10-04-2009
blueranger06's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Thanks guys seemed to have fixed the problem. We'll see how she does for the next couple days. You were right michael. I bought some mafs cleaner last night and sprayed it down and let it dry until today when I got off work. Put it in and drove around the neighborhood a couple times no problem
Reply With Quote
  #37  
Old 11-26-2011
Member
 
Join Date: Nov 2011
Location: appomattox, va
Posts: 4
i have a 88 ranger with the 2,9 and i can start it up and it runs for a few seconds and dies out when i try giving it gas. anyone know wat i need to check to get it right? i seen online that the map sensor will make it seen like the feul pumps arent workin rite but i just put a new pressure pump on it and i need help..........
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Motor will only stay running for a few seconds when it does start, please help if can Joe Green SOHC - 2.3L & 2.5L Lima Engines 2 11-29-2011 10:11 PM
Starts but won't stay running xxATMORExx 4.0L OHV & SOHC V6 Tech 7 09-20-2011 08:37 AM
Please HELP! will not stay running!!!! due to column problems 99Stranger General Ford Ranger Discussion 1 09-14-2011 09:15 PM
truck won't stay running Mogley 2.9L & 3.0L V6 Tech 11 12-12-2010 01:10 PM
Truck won't stay running blissintampa SOHC - 2.3L & 2.5L Lima Engines 5 04-26-2008 03:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.