4.0 Engine not starting - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-27-2007
Member
Thread Starter
 
Join Date: Aug 2007
Location: cary
Posts: 2
4.0 Engine not starting

The engine on my 94 4.0 XLT 4x4 is not starting. This has been an occasional problem every couple of months it would not start and then latter in the day it would start or the next day. Usually I clean the terminals and tighten the clamps on the battery and that works. This time it hasn't and the battery checked out 100%. It's a manual trans. When I turn the key it turns over and the starter is working. What should I try to get it started. Thanks
Reply With Quote
  #2  
Old 08-27-2007
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
A quick shot of starting fluid in the intake.If it fires , you have a fuel delivery problem. If it doesn't most likely ignition.
Reply With Quote
  #3  
Old 08-27-2007
Texas501's Avatar
Member
 
Join Date: Aug 2006
Location: SAN ANTONIO
Posts: 151
Don't forget the ever popular/dreaded VACUUM LEAK! You'll find lots of threads on this one.
Reply With Quote
  #4  
Old 09-04-2007
Member
Thread Starter
 
Join Date: Aug 2007
Location: cary
Posts: 2
I pulled the relay for the fuel pump and swapped with another relay that was in the box. I took the intake connection off at the EGR and sprayed to shots off starting fluid in there. Which ever it was the truck started back up.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
truck not starting just clicks country346 General Technical & Electrical 11 08-09-2016 10:22 AM
stumped 2.3 engine not starting stevenxking90 SOHC - 2.3L & 2.5L Lima Engines 8 04-07-2011 09:52 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
hard starting and not running on all cylinders part time monarchdad General Technical & Electrical 3 02-24-2007 11:33 PM
2004 Not starting Tyrant924 General Technical & Electrical 32 12-07-2004 10:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.