97 4.0L ranger temp gauge not working - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-19-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Langley
Posts: 6
97 4.0L ranger temp gauge not working

Hello I have a mazda b4000 which is pretty much a ranger. My temp gauge is not working wont even move. Its below the cold mark. I found the temp sender unit (1 wire) and the coolant temp sensor (2 wire). I pulled the connection off the sender and grounded it out and my gauge went past full hot. now to my problem. I go to buy a sender unit but the one 3 different part stores tried to sell me looks nothing like what I have. My sender unit looks exactly like my coolant sensor. is that right.
Reply With Quote
  #2  
Old 03-19-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Langley
Posts: 6
this what all the parts store try to sell me.
Attached Images
 
Reply With Quote
  #3  
Old 03-19-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Langley
Posts: 6
This is what my sender unit looks like when I take it out. Looks exactly same as my coolant sensor. just the connect to it has one wire when my sensor has a 2 wire connection. Is this correct?
Attached Images
 
Reply With Quote
  #4  
Old 03-20-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,580
Yes, that is correct
Reply With Quote
  #5  
Old 03-20-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Langley
Posts: 6
Quote:
Originally Posted by RonD View Post
Yes, that is correct
Question is then how come all my parts stores try selling me pic one then?
Reply With Quote
  #6  
Old 03-20-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,580
Not sure why?

Try 1997 Ranger 4.0l OHV temp sender, should be $10-$15, sensor is over $20
Reply With Quote
  #7  
Old 03-20-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Langley
Posts: 6
Thanks a bunch thats the exact one I needed. I'll just tell the parts store from now on I have a ranger instead of a mazda lol.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
88 ranger temp & fuel gauges not working stevie General Technical & Electrical 34 06-20-2015 09:42 AM
Gas Gauge and temp gauge help!! T12icky0 General Technical & Electrical 1 02-14-2013 03:41 PM
'96 Ranger temperature gauge not working/replacement nfazer General Technical & Electrical 8 12-06-2009 03:19 PM
Changed Thermostat now temp guage not working Rangerguy 4.0L OHV & SOHC V6 Tech 5 07-09-2009 03:40 PM
AC stops working/ temp gauge overheats Dfewer General Technical & Electrical 16 05-23-2008 10:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.