99 ranger is sick... - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-17-2014
Member
Thread Starter
 
Join Date: Nov 2014
Location: monroe
Posts: 3
99 ranger is sick...

Hi all,

I am newly registered here but I have used your forums a lot to determine issues on my truck.

I have an issue with my ranger. Driving on the freeway one day it decided to start vibrating and die on me. I can get it to start and run but it is very very rough and shakes really bad. I cannot even put it in gear while holding the brakes to be able to drive it without two footing it. It also will not start without pumping the gas pedal.

I have changed spark plugs, wires, coil pack, cleaned MAF, cleaned IAC, and everything I could think of.

I had a friend come over with a scanner, I got the P0340 code. It even stated it was a camshaft position sensor. I do not know if this would make this truck run that badly. It acts like it is starving for something.

I attempted to crawl on top of the engine and look where the actual sensor is, and man is it buried back there. I couldn't even get a socket on the sensor to attempt to pull it off. I also noticed that it moves back and forth and I am able to rotate the sensor by hand. I am not sure it is suppose to be able to move.

After searching online and in this thread multiple times I cannot find even the slightest way to go about approaching this. I am not sure if just taking the upper intake off will allow me to get to it, or If I should replace the synchronizer at the same time. I am not even sure this will fix my issue, but it is the only code that came back after clearing them the first time.

I appreciate anybody willing to help me out, or point me in the direction of how to go about doing this.

Thanks
Reply With Quote
  #2  
Old 11-17-2014
F.X.4's Avatar
Member
 
Join Date: Nov 2011
Location: Mississauga
Posts: 81
Parkinson disease?
Reply With Quote
  #3  
Old 11-17-2014
Member
Thread Starter
 
Join Date: Nov 2014
Location: monroe
Posts: 3
it is possible. I went ahead and pulled the upper intake plenum and changed the sensor. It changed nothing. Same issue, doesn't want to run idles very rough and falls to 2-300rpm and dies
Reply With Quote
  #4  
Old 11-18-2014
Member
 
Join Date: Nov 2014
Location: Syracuse
Posts: 4
Fuel filter?
Reply With Quote
  #5  
Old 11-18-2014
Member
Thread Starter
 
Join Date: Nov 2014
Location: monroe
Posts: 3
I changed the fuel filter last year when i did the engine swap. I guess it couldnt hurt to do it again. I did drive it for a few days with the check gauge light on for low fuel before this happened but it ran fine. Did not act up until i put $40 worth of gas in it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
my sick 99 ranger Sick 99 Ranger Member Introductions 39 03-18-2009 03:38 AM
Sick ranger at USF CBFranger General Ford Ranger Discussion 32 03-03-2009 10:05 PM
Sick Ranger and track pics-no56k TrucksGetDirty Snapshots 36 01-26-2009 08:03 PM
Sick Ranger... TNRanger23 2.3L & 2.5L I4 Tech 18 05-21-2008 06:16 PM
My Ranger is sick and I don't know whats wrong.. melj2000 2.9L & 3.0L V6 Tech 15 12-20-2007 11:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.