Bucking/missing - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-12-2009
Member
Thread Starter
 
Join Date: Mar 2009
Location: Ellensburg, WA
Posts: 5
Bucking/missing

My 99 4.0 OHV has been intermittently bucking/missing for about 2 weeks. It is always when maintaining a constant speed, but some days it happens 4 times and some days it doesn't happen at all. Shortly after this started it also started intermittently squeaking from the rear of the engine, same thing, some days really loud and some days just a chirp once in a while. I did some research and found that the chirp could be the cam position sensor which I just replaced tonight. It is too early to tell whether the chirping is gone but during my 1 mile test drive it bucked/missed twice. The missfire is not throwing a code, which is frustrating to say the least. The missing varies in itself from just a light buck to a major jolt. I am stumped without a code and am hoping it will eventually throw me a bone, but until then any ideas?
Reply With Quote
  #2  
Old 08-12-2009
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Crank sensor can cause timing issues as well.


Check your plugs first.
Reply With Quote
  #3  
Old 08-12-2009
leadfoot's Avatar
Member
 
Join Date: Oct 2007
Location: MA
Posts: 894
I changed my plug wires and it got rid of the bucking. The DPFE sensor on the egr system could go bad causing this problem or the egr valve can get stuck but that will usually throw a code.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck is bucking, sputtering and missing...Need help please! cchsbuzz19 4.0L OHV & SOHC V6 Tech 25 08-22-2012 07:01 AM
4.0 skip/misfire/bucking OVERtheEDGE 4.0L OHV & SOHC V6 Tech 49 02-16-2009 08:31 AM
bucking, kicking, rough idle sams dad 4.0L OHV & SOHC V6 Tech 17 10-10-2007 07:11 PM
Bucking 2.5L ranger1998xlt SOHC - 2.3L & 2.5L Lima Engines 1 02-06-2007 12:35 PM
Running really bad-Stuttering-Bucking bmxrider379 4.0L OHV & SOHC V6 Tech 4 09-11-2006 07:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.