check engine light + idle issue - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-30-2009
Alucard's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2005
Location: Saxonburg, PA
Posts: 91
check engine light + idle issue

i had a check engine light come on the other day, got the code read and it was "bank 1 too lean" got the code cleared and now its back on. this would be the drivers side oxygen sensor causing this code correct? and now for the idle issue, once in a while when the truck is at idle the rpms will drop to allmost stalling and then jump back up to idle. what would cause this? where should i start?

thanks
Reply With Quote
  #2  
Old 07-30-2009
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Unplug the battery, toggle your lights on for a few seconds to kill any extra power in the system.. then unplug yoru MAF, clean that out, and plug it back in and let it idle for 5 minutes.. if it stays on, you can try popping off your O2 sensor and spraying soem electrical cleaner on it
Reply With Quote
  #3  
Old 07-30-2009
Alucard's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2005
Location: Saxonburg, PA
Posts: 91
i did as stated above by mike. the last time it took it a day for the light to come back on so we'll see what happens. anybody got any ideas on my idle issue.

thanks
Reply With Quote
  #4  
Old 08-04-2009
Alucard's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2005
Location: Saxonburg, PA
Posts: 91
i cleaned the MAF and the IAC but both problems continue. the idle problem is when i come to a stop or drop it into park the idle drops almost to the point of stalling then jumps back up to idle and kind of bounces around for a minute but does eventually stabilize. could this be a symptom of a bad o2 sensor? both problems started around the same time.

thanks
Reply With Quote
  #5  
Old 08-04-2009
Flakbadger's Avatar
Member
 
Join Date: Feb 2009
Location: Portland, OR
Posts: 70
Quote:
Originally Posted by Alucard View Post
the idle problem is when i come to a stop or drop it into park the idle drops almost to the point of stalling then jumps back up to idle and kind of bounces around for a minute but does eventually stabilize.
I would like to begin by saying I am NOT a great mechanic myself. When it comes to diagnosis, I'm usually not so hot. HOWEVER, I drove a beater of a Toyota on my vacation this year, and it would idle that way. Almost die, rev up to idle, almost die, rev up to idle. Turns out it had a couple of vacuum leaks and a faulty heat sensor. The sensor was getting a reading from the engine compartment heat mixing with the airbox temperature air... and the sensor was fXed.

It sounds to me like this engine is doing the same thing. But the difference is, this is a modern Ranger and the 'Yota was from the mid 80s

Anyway, good luck my friend.
Reply With Quote
  #6  
Old 08-08-2009
Member
 
Join Date: Apr 2007
Location: torrington ct
Posts: 156
sounds to me like you need a new iac from ford dont go to auto zone they suck.
what year is your truck there is always a possibility that it could be a intake gasket leak.
Reply With Quote
  #7  
Old 08-09-2009
Member
 
Join Date: Mar 2005
Location: Wichita, KS
Posts: 1,301
Reply With Quote
  #8  
Old 08-24-2009
Alucard's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2005
Location: Saxonburg, PA
Posts: 91
Quote:
Originally Posted by soccerjohn View Post
thanks i'll have to check that out later today.

my idle issue isn't as bad after spraying some electronics cleaner up into the egr pressure feedback sensor

Last edited by Alucard; 08-24-2009 at 01:32 PM.
Reply With Quote
  #9  
Old 08-24-2009
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Look for a vaccum leak.
Reply With Quote
  #10  
Old 08-25-2009
Jazz921's Avatar
Member
iTrader: (2)
 
Join Date: Sep 2007
Location: Evansville, IN
Posts: 997
clean your throttle body!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
o/d light, check engine light and rough idle wtf man 2.9L & 3.0L V6 Tech 8 02-23-2014 01:39 PM
Unknown Check Engine Light Issue nathan01xl General Technical & Electrical 1 05-31-2012 06:03 AM
Ruff idle after Sea Foam, check engine light on russian 2.9L & 3.0L V6 Tech 11 02-26-2011 09:01 AM
Check Engine light issue dmety87 SOHC - 2.3L & 2.5L Lima Engines 11 06-14-2007 07:45 PM
Rough idle, check engine light SnowGoAK 4.0L OHV & SOHC V6 Tech 6 06-24-2005 04:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.