hesitant and jerky! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 12-07-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Quote:
Originally Posted by lifted97ranger
it is what gives your spark plugs spark....it is what the opposite end of your spark plug wire attach to (other end from the plugs)...it is by the intake manafold on the passanger side toward the firewall, on top of the engine....

OOOOO OK OK, I gotcha, Are they expensive to replace? do you know of? Hard to replace?
Reply With Quote
  #27  
Old 12-07-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by fletch12518
OOOOO OK OK, I gotcha, Are they expensive to replace? do you know of? Hard to replace?
I called the O'Reilly Auto Parts in Charlestown, they have a off brand for $65 and they can get Motorcraft (takes 1 day to get it in) that is $104.....if i replace mine, i am going to get the Motorcraft part... If you replace it Shane, do yourself a favor and dont buy AutoZone parts....
Reply With Quote
  #28  
Old 12-07-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Quote:
Originally Posted by lifted97ranger
I called the O'Reilly Auto Parts in Charlestown, they have a off brand for $65 and they can get Motorcraft (takes 1 day to get it in) that is $104.....if i replace mine, i am going to get the Motorcraft part... If you replace it Shane, do yourself a favor and dont buy AutoZone parts....

Im going to go with motorcraft parts. When it some to things like this
Reply With Quote
  #29  
Old 12-07-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
meee tooo the only other option i was thinking about is the Demon coil pack from Underdog Performance, but it would take longer for it to get here....
Reply With Quote
  #30  
Old 12-07-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Is it that bad???? Mine jerks proply once or twice a day. I drive prop about 75miles everyday.
Reply With Quote
  #31  
Old 12-07-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
yea i dont want to drive it is so bad........

when it is running you can hear the engine run rough....the hood shakes when it is up....and when you hold your hand at the exhaust tip, there is not a steady flow of exhaust gases that comes out......i checked that against my moms '97 explorer 4.0 and it flows a steady flow of exhaust gases.....that is how i determined that it had a miss in it....
Reply With Quote
  #32  
Old 12-07-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
hmmmmmmmmmmmm wow, mines not like super smooth, but i think it flows ok
Reply With Quote
  #33  
Old 12-07-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by fletch12518
hmmmmmmmmmmmm wow, mines not like super smooth, but i think it flows ok
yea on my moms Explorer, it is smooth as a wistle..... i need to get this resolved before any more snow! mom has 4wd, but she can't go anywere in the deep stuff so everyone relys on me to get things we need in the deep stuff...
Reply With Quote
  #34  
Old 12-07-2006
FMD's Avatar
FMD FMD is offline
Member
iTrader: (1)
 
Join Date: Aug 2005
Location: Amherst NY
Posts: 3,811
could also be the alternator too.... u ask how this could be... well i had this in my car. and found out about this AFTERi sold it. the alternator could spike, and burn out the coil pack and distributor parts causing themn to fail prematurely (i went thru 9 distributors in 3yrs) so if u have this problem again in like 3-6 months..... start looking at the alternator.
Reply With Quote
  #35  
Old 12-08-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
um on my way to work this morning, MY tuck jerked like hell!????? When It started to Jerk I pushed down the gas pedal to get higher speeds to run smoother. The thing would stay in second gear no matter how hard I pushed the gas????? Than Id taked my foot off the gas, than hit it again and it finally spiked up to a higher rpm and gear. WTF!
Reply With Quote
  #36  
Old 12-08-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
same problem with my truck Shane........i am going to work on her tomorrow morning and i will let you know what i did to fix it....
Reply With Quote
  #37  
Old 12-08-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
sweet I would love to know!!!! thank you!!!!!
Reply With Quote
  #38  
Old 12-08-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
no problem my man....
Reply With Quote
  #39  
Old 12-08-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
aight........check the coil pack and plug wires, not that problem.......i noticed when you rev it up and let it fall back to idle, there is s poping noise on rev up and then again on rev down......

any suggestions?
Reply With Quote
  #40  
Old 12-08-2006
04lvl2's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Palm Bay, FL
Posts: 5,600
Check compression, you have a air compressor? You know how to do a cylinder leakage test?
Reply With Quote
  #41  
Old 12-09-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by 04lvl2
Check compression, you have a air compressor? You know how to do a cylinder leakage test?
got an air compressor, but have no clue on how to check compression....
Reply With Quote
  #42  
Old 12-09-2006
LoOnaTik's Avatar
Member
 
Join Date: Oct 2006
Location: Morristown,Tn
Posts: 477
Don't know if anyones suggested or if you've already checked but i had a similar prob and it was a vaccum leak, idk just a suggestion.
Reply With Quote
  #43  
Old 12-10-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by LoOnaTik
Don't know if anyones suggested or if you've already checked but i had a similar prob and it was a vaccum leak, idk just a suggestion.
i will retrace the lines today , but i dont think i have a leak....
Reply With Quote
  #44  
Old 12-14-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
did ya figure it out yet................?
Reply With Quote
  #45  
Old 12-14-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
yea......it had a dead plug....it finally threw a code and it said it was a missing #3 cylinder......swapped out the plug and it runs like a new engine.....
Reply With Quote
  #46  
Old 12-14-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
damn, okay than where did you go to get the code read? I take it your check engine light came one?
Reply With Quote
  #47  
Old 12-14-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
yea my check engine light came on when i was taking it to my gf's uncle for him to look at......so i went to the AutoZone by his house and they pulled the code for free.....

i got my it to give a code by unplugging the IAC when it was running.....the only reason i unplugged it is because it was idleing real rough (because of the miss) and i wanted to see if that was the problem......then it shot a code....
Reply With Quote
  #48  
Old 12-14-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
ok well my problem may be that the spark plug is now screwed in all the way....? The plug on the driver side closest to the fire wall. I can not tighten that bugger too much. I broke 2 plugs (glass houssing) trying to tighten it. I had a swivel joint, spark plug socket and tried a wrench and still can't get it all the way tightened...........? That just may be my problem.
Reply With Quote
  #49  
Old 12-14-2006
lifted97ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
could be.......take out each plug and make sure that it is getting spark.....if you find one that isn't, then you need to then see if the wire is sending spard, then if that aint it, then check the coil pack....

there is a test in the Haynes manual on how to check the coil pack...
Reply With Quote
  #50  
Old 12-14-2006
Member
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
i may need to buy that book
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stalling / Jerky in 2nd gear matteusclement SOHC - 2.3L & 2.5L Lima Engines 2 06-23-2013 04:09 PM
Want to do the Overlay and LED Cluster mod, but hesitant, warlocke General Ford Ranger Discussion 12 02-05-2012 02:42 PM
2004 2.3L, jerky and stumbles on acceleration Jbrando03 DOHC - 2.3L Duratec / Mazda L Engines 2 11-12-2011 10:19 PM
Auto Trans. jerky Wolgy Drivetrain Tech 5 11-19-2009 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:34 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.