Iam Stupid i need Help Badly - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2005
SteveOh's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: Ft. Campbell Kentucky
Posts: 4,585
Iam Stupid i need Help Badly

iam only get 9mpg in my ranger with no engine modifications and its eating me alive..i was thinking of getting rid of it but its my baby and i cant get rid of it but i need to find out what i need to do to fix her toget what she is supposed to get with no a/c running on a full tank i get 140 miles!!! iacquired this truck at 58k miles and i dont know if there has ever had a tune up on it but i need some help!! i know it has the original i mean original spark plugs and wires...so what do i need to do to fix here to get iot right!!
Reply With Quote
  #2  
Old 08-31-2005
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
****... i get like 15-16mpg with 32's
Reply With Quote
  #3  
Old 08-31-2005
FoMoCoFiddy's Avatar
Member
 
Join Date: May 2004
Location: Smackdownville Tx
Posts: 4,508
lots of stuff..

proper tire wear and balance

Air pressure

fuel filter

plugs and wires

peice of 2x4 under the pedal

air intake filter

clean the MAF

and reset the computer by disconnecting the battery, then reconnecting it and let it idle for about 15 min.

My personal recommendations.

And of course, oil change and maintenence.


I get 18mpg in my stang.
Reply With Quote
  #4  
Old 08-31-2005
HarryTasker's Avatar
Member
 
Join Date: Jan 2005
Location: Portland, OR
Posts: 1,491
here is what is happening.

1.Something is wrong with your trucks engine. See if a local dealer can reflash your trucks computer. there have been a few new programs out. I had mine done in february and my mileage went up 2 mpg.

2.there is a whole some where.

3.Some one is stealing your gas.
Reply With Quote
  #5  
Old 08-31-2005
SteveOh's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: Ft. Campbell Kentucky
Posts: 4,585
ithink the people who had it b4 me didnt maintain it besides the oil iam running 31's i have the egr flow insufficient code also but b4 that came on i was still getting shytty mileage and i NEVER run the a/c so that isnt a factor every since i had it i have changed the oil every 3,000 miles but have never replaced anything like an fuel filter or anything besides a oil change and air filter the cheppy crappy 1
Reply With Quote
  #6  
Old 08-31-2005
SteveOh's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: Ft. Campbell Kentucky
Posts: 4,585
2.there is a whole some where. nope had it checked...lol

3.Some one is stealing your gas.nope my truckis garaged and i know ever1 around me


WTF is a peice of 2x4 under the pedal going to do...i dont drive with the pedal to the floor if thats what u are talking about there is no need to unless iam on the highway but i hardly ever go there
Reply With Quote
  #7  
Old 08-31-2005
shadyluke's Avatar
Member
 
Join Date: Mar 2005
Location: West Grove, PA
Posts: 2,077
First get the EGR replaced. If itz throwing a code itz probably your culprit. As for it doing this prior to the code it has to start going at some point before the code is set off.
Reply With Quote
  #8  
Old 08-31-2005
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
Plugs. Fuel filter.
Reply With Quote
  #9  
Old 09-01-2005
karrbass4life's Avatar
Member
 
Join Date: Nov 2004
Location: Cincinnati, Ohio
Posts: 3,072
Start with the simple stuff and move on to the harder stuff and CHANGE THOSE PLUGS AND WIRES.
Reply With Quote
  #10  
Old 09-01-2005
01xltranger4x4's Avatar
Member
iTrader: (3)
 
Join Date: May 2005
Location: MI
Posts: 3,200
Are you sure you are calculating your MPG right? I know i may sound stupid, but its a common mistake.

You should be getting AT LEAST 12 MPG.

I am getting 15-16 City, and 18-19 Highway.....with 33's.....
Reply With Quote
  #11  
Old 09-01-2005
Carrottop688's Avatar
Member
 
Join Date: May 2005
Location: Portland, Oregon
Posts: 102
He could be driving it irradically...try keeping your acceleration under control (Shift below 2500 rpms, or if you have an auto let your tranny shift cleanly by keeping your rpms in check) ... Either its your driving (no offense) or its your engine, I would try trying to correct your driving...which wont cost you anything rather than going in to get the shop to do something that might not be the root cause... MPG=miles/gallons used...I think...

Try that, see if it works out for ya.
Reply With Quote
  #12  
Old 09-02-2005
vansnxtweek's Avatar
Member
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
its the underbody kit weighing you down.....:)
but ya do what they said, get the egr fixed, do plugs, wires, fuel filter, and check your air filter
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I need a passenger seat badly! inavacuum Interior Semi-Tech 1 10-12-2010 02:54 PM
STUPID!STUPID!STUPID! jtfoxman General Ford Ranger Discussion 14 07-30-2009 12:42 AM
need help badly sideswipe General Technical & Electrical 4 08-09-2008 10:10 PM
Need Help Badly!!!!! 04edge General Ford Ranger Discussion 10 02-06-2006 04:17 PM
Stupid, stupid man.... aftermarket Suspension Tech 16 07-20-2005 03:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:22 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.