Leaking Oil/Rough Idle - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-18-2010
fordboston's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Lodi, CA
Posts: 52
Leaking Oil/Rough Idle

Hey guys,
It's been a while since I've been on here and posted and asked questions about my truck and here I go again! Sorry! LOL

My truck is still leaking oil and rough idling. I have had my valve covers replaced and my rear main seal as well. When I'm driving, I can smell burning oil and after a couple days, my check oil light will come on and I just have to add about half a quart and it will be fine for another couple days after that. I have had my mechanics at work look at it, and they can't physically see where the oil is leaking from, but after I drive it, even just for a couple minutes, when I park, I see oil on the ground. Also, when I'm driving, my air nor heater will be on, but there is warm air blowing from the vents, the faster I go, the more it blows.
Also, when I start the vehicle, it takes some time to start itself up, as if it's lagging or a sticky starter. Now, I know it's not the starter, but what else could it be?!

Is this a common problem on your vehicles, and if so, what and how do I fix this and what could be the problem?

I appreciate the time to look at this thread and I really hope that somebody, anybody, can help me!
Reply With Quote
  #2  
Old 05-18-2010
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
probably your rear crankshaft seal

leaking through the transmission inspection cover
Reply With Quote
  #3  
Old 05-20-2010
Member
 
Join Date: May 2010
Location: Bucks County, PA
Posts: 6
Quote:
Originally Posted by fordboston View Post
Hey guys,
It's been a while since I've been on here and posted and asked questions about my truck and here I go again! Sorry! LOL

My truck is still leaking oil and rough idling. I have had my valve covers replaced and my rear main seal as well. When I'm driving, I can smell burning oil and after a couple days, my check oil light will come on and I just have to add about half a quart and it will be fine for another couple days after that. I have had my mechanics at work look at it, and they can't physically see where the oil is leaking from, but after I drive it, even just for a couple minutes, when I park, I see oil on the ground. Also, when I'm driving, my air nor heater will be on, but there is warm air blowing from the vents, the faster I go, the more it blows.
Also, when I start the vehicle, it takes some time to start itself up, as if it's lagging or a sticky starter. Now, I know it's not the starter, but what else could it be?!

Is this a common problem on your vehicles, and if so, what and how do I fix this and what could be the problem?

I appreciate the time to look at this thread and I really hope that somebody, anybody, can help me!
Honestly, leaky oil is tough to diagnose without seeing it... the quick and dirty way to trace oil leaks is to clean up all the caked on oil (or at least the oil that's around where the leak is generally coming from), drive it, then look for the path the oil has taken. Place a large piece of cardboard under your car after driving it, trace the drops to where they fell off the motor, should give you a place to start.

As for the rough idle can also be a number of things, but first check all vacuum connections and make sure there is no leak. Is the engine throwing a CEL? If so, it'll provide some more clues. If vacuum connections are set, then check/replace plugs and wires (if it hasn't been done within the last 60k). Rough idle plus a lean CEL usually points towards vacuum leak.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
M5OD rough shift on rough roads, potholes, speed bumps Mike_92 Drivetrain Tech 0 10-28-2013 10:26 PM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM
leaking oil pan gasket? 04edge 2.9L & 3.0L V6 Tech 5 02-28-2006 10:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.