Loss of Power, Sounds like Vacuum Leak - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-05-2008
herm59's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Toms River, NJ
Posts: 1,694
Loss of Power, Sounds like Vacuum Leak

Ok, so for the past couple of months it sounds like I have a vacuum leak somewhere, but I canít pinpoint it. I loose power under acceleration. I have cleaned my MAF numerous times, cleaned my filter (K&N), changed plugs, wires, and fuel filter. My CEL does not come on. I have searched on here and came up with nothing. The only thing I can possible think of is the PVC tube, but I looked at it and looks ok (a bit tough to stay outside longer then 10mins with the cold air). Iíve been getting under 13mpg and its killing me. I also have to worry if Iím going to be able to merge into traffic. Any help would be greatly appreciated thanks.

The truck is a 2001 XLT 4x4 4.0 SOHC with 109,000 miles.
Reply With Quote
  #2  
Old 12-05-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
If it was a bad enough vacuum leak to cause a lack in power, I'd think you'd see a CEL with a stored code of running lean?

I suspect the IAC is hanging open causing the noise and lack of power.
I'd unplug it and go for a drive to see if it's got more power. This might throw a CEL.. don't sweat it. It'll just not idle right or might die. But under power it ought to act pretty much the same.

Rich

Last edited by wydopnthrtl; 12-05-2008 at 01:58 PM.
Reply With Quote
  #3  
Old 12-05-2008
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
get a can of starting fluid or carb cleaner and spary it on the vacume lines if it runs beater wher you sprayed ther your problem try that
Reply With Quote
  #4  
Old 12-09-2008
herm59's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Toms River, NJ
Posts: 1,694
Well I unplugged the IAC and the truck barely started and w/out keeping my foot on the gas it would die.

What now?
Reply With Quote
  #5  
Old 12-09-2008
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
intake manifold gasket bad
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
sounds like an exhaust leak but its not 59Impal 4.0L OHV & SOHC V6 Tech 2 09-21-2011 04:11 PM
93 Ranger Loss of Power at WOT intake sounds loud lvpump SOHC - 2.3L & 2.5L Lima Engines 3 01-23-2011 06:34 PM
sounds like a lifter tap at 3500rpms?? meeky3482 2.9L & 3.0L V6 Tech 5 09-18-2008 07:20 PM
Ranger Sounds Like A Diesel pawsino General Technical & Electrical 13 11-21-2006 05:57 AM
Cherry Bomb sounds like [email protected]#..no doubt chukzie General Ford Ranger Discussion 25 06-30-2005 03:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.