Need Help with 2003 Ranger 4.0 llitre - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-03-2011
bluedragon's Avatar
Member
Thread Starter
 
Join Date: Mar 2011
Location: Brampton, Ontario
Posts: 9
Need Help with 2003 Ranger 4.0 llitre

Just wanted to say hello to everyone, I am new to the site and I know there are many Ranger Enthusiasts here and I am hoping that someone can help me with my problem. I own a 2003 Ranger FX4 , been a great truck up until a few days when I got a check engine light that was blinking after start up. I am a fourth year apprentice and I work on my own cars. I scanned the truck and it came up with misfire codes for cylinder # 1, 2 and 3 , all on one side, Now this might be a coincidence but I also had no heat at that time. I checked for vaccum leaks and intake leaks , no problems found, I did a compression test on cylinder 1 and it fluctuates and the highest reading I ever get like 90 psi ,at times ever drops down to 40 psi hence its an internal issue. I also hear the chain ratlle on ocassions. My first guess the chain given the fact that Ford has issues on the older 4.0 SOHC engines. I did a coolant pressure test and it holds pressure and no leaks detected so that kind of rules out a head gasket issue. The mileage is current at 331,000 kms which when converted would be approx 205,000 miles. Has anyone come across any problems or guide me as to what to do next. Your help is very much appreciated.
Reply With Quote
  #2  
Old 03-03-2011
04XLTFX4's Avatar
Member
 
Join Date: Jan 2011
Location: Huntingdon,Pa
Posts: 191
Ive seen it a couple times. Both times the enough plastic had broke and fallen out on the rear, bank one tensioner the the chains play was letting bank one out of time. Is the noise coming out of the pass side wheel well toward rear of motor? One was so bad it bent the valves in bank one.
Reply With Quote
  #3  
Old 03-03-2011
bluedragon's Avatar
Member
Thread Starter
 
Join Date: Mar 2011
Location: Brampton, Ontario
Posts: 9
As far as the noise goes it sounds more from the front near the fan clutch but then again I will make sure just to be at peace of mind. I know for a fact its a chain rattling.
Reply With Quote
  #4  
Old 03-09-2011
bluedragon's Avatar
Member
Thread Starter
 
Join Date: Mar 2011
Location: Brampton, Ontario
Posts: 9
ok I drove my truck for a whole day ...no CEL , no misfire , was driving fine and today the same problem ...misfire on Cylinder 1 , 2 and 3 and also 2 other codes one said O2 sensor stuck open and running rich and the last code was misfire detected during the first 1000 RPM's . Has anyone come across any similar issues. I just want to make sure that it is not something else that can be fixed other then replacing the motor.
Reply With Quote
  #5  
Old 03-20-2011
HouseofFinch's Avatar
Member
 
Join Date: Sep 2010
Location: Calgary, Alberta
Posts: 28
I have the exact same issues with my '04 4.0L SOHC. But mostly on cyl. 3. It runs fine during normal driving, but under hard acceleration at higher rpm's it starts to stumble. Also during idle it gets the misfire. If I shut the truck off and re-start it the misfire goes away, for a short time until I stop at another red light. I have replaced the coil, wires, plugs and fuel filter to no avail. I had a coolant leak that has caused the crank trigger sensor to get all covered in grime, so that's my next thing to look at, as well as cleaning the MAF sensor.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help with 2003 OEM AM/FM CD GMG Audio & Video Tech 3 08-28-2013 08:28 AM
Help with 2003 no start please help klc317 4.0L OHV & SOHC V6 Tech 1 07-13-2013 08:36 AM
Spark plug Gap? Poor idle? 2003 4.0 Need HELP! dczys General Ford Ranger Discussion 7 11-21-2012 01:37 PM
Need 2003 4.0 SOHC Flywheel Help ASAP! l2en Drivetrain Tech 13 03-23-2007 01:09 PM
2003 Taurus - Heating/Cooling Fan Question - Need help quick - Bob? mental ambiguity General Technical & Electrical 11 07-05-2006 09:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.