Random Stalling/Starting Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-18-2009
BassMaster5000's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Niceville, FL
Posts: 2
Random Stalling/Starting Problem

About 2 weeks ago, I was taking off in first gear, got to about 3k rpm, and I lost pretty much all "acceleration." I had been driving all day, without any problems. It was like I took my foot off of the gas to slow down, yet I was still pressing the pedal, but no matter how much gas I "tried" giving the engine, the rpm's kept dropping. I tried pushing in the clutch to save it before it stalled, but it was no use, she died. While rolling through the intersection I tried to start the engine back up, but got nothing. I rolled off the side of the rode, took the key out, then replaced it and tried to start the truck again.. Nothing. I ended up having to get towed just down the road to a parking lot where I could leave it over night. Came back the next morning on the way to work to grab my wallet which I forget, and tried to start her up for ****s and giggles. Suprisingly, it started right up, and everything seemed normal, not idling rough, no wierd noises/smells, nothing. I decided take a chance, and drive to work while my friend followed me. I made it fine, and drove it a whole week without problems until the same thing happened again. Driving home from work, made it all the home, pull into a spot, then decide to move because I had parked next to a jackass that didnt care about his car, so I back out, and as soon as I put it in first to take off, she dies. I push in through the parking lot to another spot, same thing as last time, wouldnt start. I tried filling my gas tank, I pulled a spark plug, turned it over, and could smell gas, checked and didnt see a fuel leak, eventually gave up and brought it in to the local Mazda dealership, pretty much only place near me. They had it for 2 days, couldnt find anything wrong, and called me back saying that there was no problems with the truck. Since Ive had it back, (2-3) days, I havent had a problem, but I kno theres got to be something wrong... I searched other forums but didnt find anything like this, so I was wondering if anyone had this happen to them, or had heard of this happeneing..
Reply With Quote
  #2  
Old 08-18-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
No codes ? Try swapping out the fuel pump relay.
Reply With Quote
  #3  
Old 08-18-2009
BassMaster5000's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Niceville, FL
Posts: 2
nope, didnt throw any codes.. Ill try that, should be like 30 or 40 bucks.. I also had a couple different people tell me that it could be my ecm. You think thats a possibility?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 ranger stalling problem Goford! 4.0L OHV & SOHC V6 Tech 5 08-15-2015 12:06 PM
Random Stalling? ChaosFromAbove 2.9L & 3.0L V6 Tech 50 04-22-2011 09:49 PM
Starting Problems// Stalling at Highway Speed 05 Ranger nross 4.0L OHV & SOHC V6 Tech 10 03-20-2010 07:59 AM
Some Random Pic's ........In Random Places DallyBoy09 Snapshots 11 06-28-2009 10:38 PM
stalling problem unoh95ranger 4.0L OHV & SOHC V6 Tech 5 12-24-2007 02:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:38 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.