Randomly wont start?? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-27-2008
dantheman's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: San Jose CA
Posts: 238
Randomly wont start??

I have a 2002 ford ranger edge 4.0 with about 68000 miles on it. Recently it started randomly not starting. I took it to the shop and he said that i might have a bad battery which would make the computer tweek out. so i replace the battery and yet it will still radomly not start. Iv noticed that it will usually do it after the truck has been sitting for a couple hours. It will turn over but not turn on. Iv tried giving it gas when its turning over and still nothing. When this happens i usually just sit there for about 20 min and it will start right up. sometimes it will turn on and sputter a little bit and die. When im driving the truck runs amazing. Any Ideas??
Reply With Quote
  #2  
Old 12-28-2008
DSFD506's Avatar
Member
iTrader: (2)
 
Join Date: Jul 2007
Location: Anderson, SC
Posts: 702
You know i've had this problem a few times myself. It will sit there and turn and turn and turn but never starts. After a few tries it starts right up. And of course when I take it to the dealership to get checked out, everything is all perfect.
Reply With Quote
  #3  
Old 12-28-2008
Member
 
Join Date: Apr 2007
Location: torrington ct
Posts: 156
could this be fuel pressure related? try turning the key on and off a couple of time to prime the system and see if it starts fine.
Reply With Quote
  #4  
Old 12-28-2008
Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Livonia, MI
Posts: 489
When are you having this problem? Any specific time? Mine does the same exact thing when it is realy moist outside. It could be from the MAF sensor getting moist. Could also be the fuel pump loosing prime, Fuel system bleeding down when it sits.
Reply With Quote
  #5  
Old 12-28-2008
dantheman's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: San Jose CA
Posts: 238
yeah iv notice that it happens at night when it is misty out side or early in the morning when its misty too.
Reply With Quote
  #6  
Old 12-29-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
My first thought is fuel filter.

Try turning the key to the igniton on position, wait 5 seconds, turn off, turn it back on, wait 5 seconds, then see if it fires. If that seems to work... replace the fuel filter.

Rich
Reply With Quote
  #7  
Old 12-29-2008
Melt's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Denver, CO
Posts: 3,392
what about a relay of some sort? This was the problem when my moms 91 accord wouldnt start on warm days
Reply With Quote
  #8  
Old 12-29-2008
dantheman's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: San Jose CA
Posts: 238
well its the morning time and yet again that 4.0 beast didnt start. i moved the key to the ingnition position 3 times and that bad boy fried right up... so i guess i need a new fuel filter
Reply With Quote
  #9  
Old 12-29-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Quote:
Originally Posted by Dantheman88125 View Post
well its the morning time and yet again that 4.0 beast didnt start. i moved the key to the ingnition position 3 times and that bad boy fried right up... so i guess i need a new fuel filter
Chances are very good that's all that's wrong. And it's the cheapest *guess* too. If it continues then maybe it's the fuel regulator... or what ever holds the fuel pressure after shut off.

Rich
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck wont turn over (randomly) PDXracer SOHC - 2.3L & 2.5L Lima Engines 3 10-06-2014 08:41 PM
Signal lights randomly don't work... Ciaran General Technical & Electrical 9 09-23-2008 01:08 PM
Randomly better gas mileage Werty 2.9L & 3.0L V6 Tech 26 11-20-2006 05:37 PM
Air flow goes to defrost randomly GubNi General Technical & Electrical 29 08-12-2006 10:57 AM
4x4 randomly working, electical problem? QWIKSNK Drivetrain Tech 11 06-13-2006 02:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.