rough idle when starting warm - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-06-2014
CAW's Avatar
CAW CAW is offline
Member
Thread Starter
 
Join Date: Apr 2005
Location: southern indiana
Posts: 137
rough idle when starting warm

Ok, I have been having an idling issue. Several years ago I replaced all my intake gaskets due to p0171 & p0174 codes. It fixed the issue. However, the codes, about 7 years later, have returned during cold weather along with a rough idle. this happens during cold weather only. Now that it has warmed up outside, the truck has developed another curious issue. I will go for a drive, shut it off, then restart. The idle will be very rough for about 1 minute then smooth out and run fine. this warm weather rough idle only happens when the engine is already warm. Any ideas what might cause this? I'm thinking it may be best to simply replace all the gaskets again. But this issue seems like it might not be vacuum leak related, the truck has no problem idling after it has had a minute to run. I have checked the hoses for vacuum leaks/cracks and sprayed a bottle of carb cleaner on the engine with no definite results. Any input is appreciated.

4.0 ohv 158,000miles
Reply With Quote
  #2  
Old 04-07-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,608
Dirty MAF sensor is a know issue with Ranger 4.0ls

Yes, p0171 & p0174 is almost always a vacuum leak, but could be lower fuel pressure
Reply With Quote
  #3  
Old 04-08-2014
CAW's Avatar
CAW CAW is offline
Member
Thread Starter
 
Join Date: Apr 2005
Location: southern indiana
Posts: 137
Did some more testing, I hooked up my obd reader which can graph out engine rpm. I sprayed carb cleaner in several areas. The rpm spiked several times, but not every time, when I sprayed near the IAC valve. I also had a few spikes when I sprayed the upper intake to fuel rail gaskets. I can't understand why spraying the same areas won't always cause a rpm spike?
Reply With Quote
  #4  
Old 04-12-2014
CAW's Avatar
CAW CAW is offline
Member
Thread Starter
 
Join Date: Apr 2005
Location: southern indiana
Posts: 137
Update:

I made a leak smoke tester out of an old paint can and a glow plug, hooked it an air compressor and to the engine intake. Smoke poured out of the IAC where the solenoid is crimped to the valve body. The EGR valve also leaked badly. I bought both replacement parts. However the EGR tube nut doesn't not want to come loose.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Periodic rough idle when warm galaxyflyer1 General Technical & Electrical 1 04-06-2016 08:55 PM
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM
Warm starting issue paddd 4.0L OHV & SOHC V6 Tech 1 03-31-2010 07:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.