runability problems - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-10-2014
Member
Thread Starter
 
Join Date: Oct 2014
Location: belgrade
Posts: 1
runability problems

Hello everyone ive got a 2006 Ranger with a 4.0 sohc 4x4 with almost 110000 miles on it. Just gave it a tune up(Ignition module, plugs, wires, air filter and so on). The truck ran perfect before all this and now it just runs like garbage! runs rough, shakes the whole truck at idle, it smooths out around 2000 rpm. backfires when driving it around. and its got the bad rotten egg smell out the exhaust. I was looking at the plug wires on the driver side in the dark last night and I can see them light up. not sure what that means all wires are new????????? any help would be much appreciated! like I said before the thing ran fine before I worked on it that's usually what happens when I work on something though haha!
Reply With Quote
  #2  
Old 10-10-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
you have some mis run 1 or 2 ignition wires

when you replace ignition wires , only replace 1 at a time , this prevents you from making a mistake
Reply With Quote
  #3  
Old 10-10-2014
06FordFX4's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2012
Location: Canada
Posts: 694
yep. id guess two wires are mixed up, or shitty plugs.
what brand of plugs and wires did you use?

use this to make sure your wires are running to the right plug

Reply With Quote
  #4  
Old 10-12-2014
Member
 
Join Date: Aug 2008
Location: Taylor, Michigan
Posts: 96
That's typical of a crossed plug wire or two.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 02:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 11:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 09:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 02:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.