Weird fuel issue in my 94.. - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-28-2013
Member
Thread Starter
 
Join Date: Dec 2012
Location: St.Louis
Posts: 7
Weird fuel issue in my 94..

I have a weird on going issue that after I get fuel, I go to start the truck and it just cranks and cranks. Then after five or so minutes it starts up.. Im stumped?? Im not sure if the pump is kicking on or not?? I take the fuel pump relay out and put it back it, and that usually is the trick..but other then after I get fuel it always starts right up..
Reply With Quote
  #2  
Old 02-05-2013
Member
 
Join Date: Mar 2010
Location: Roy, Utah
Posts: 25
The fuel is causing your problem. I know, Duuuh! Now for more: 1. It could be a loose connection of the fuel pump in the tank. Buying fuel moves it enough so it doesn't make contact. Possible, but unlikely.
2. The weight of the fuel causes a part of your vehicle to contact the fuel pump electrical wiring. It may open up the wire - like flipping an off switch to the fuel pump. Moving around in the truck may cause contact of the wires again. The fuel weight may also cause a short circuit in which the fuel pump is involved. I can't tell you exactly how this might occur because there are several possibilities. One would cause the fuel pump fuse to blow. Since you didn't mention that happening, I would eliminate a short from power to ground in the fuel pump circuit and concentrate on a short from one power wire to another. What else is in the fuel pump wiring harness? Look at that and see if there is a problem with anything else within that harness. If so, that is what you need to fix. Hope this isn't too generic to help. Good luck.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Want to Buy: Fuel line between fuel filter & fuel pump - TN iplayloudly Interior, Exterior, Electrical, & Misc. 7 05-02-2012 04:10 PM
Is it a timing issue or a fuel issue? Drewbis SOHC - 2.3L & 2.5L Lima Engines 7 08-13-2010 07:16 AM
Weird electrical issue uhittheuglytree General Technical & Electrical 2 02-19-2010 03:07 PM
Weird Air Conditioning Issue...Help Prerunner-Ranger General Technical & Electrical 21 08-16-2008 10:04 AM
Weird overheating issue RANGERMAN66 4.0L OHV & SOHC V6 Tech 5 12-08-2007 06:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:28 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.