head unit signal issues - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-11-2012
Member
Thread Starter
 
Join Date: Oct 2011
Location: connecticut
Posts: 150
head unit signal issues

i recently put in a new pioneer head unit. the install went fine and it looks awesome. but i dont get all of my stations. i only get about 6 and half of them are static. also the ones that i can hear have static in them. any idea on how i can fix this i emailed crutchfield but they havent gotten back to me yet. do i need an antenna adaptor? my antenna is the stock one i havent modified it at all.
Reply With Quote
  #2  
Old 01-12-2012
RangOH's Avatar
Member
 
Join Date: Feb 2009
Location: Madison, Ohio
Posts: 854
Well since you bought it for crutchfield i would work with them just due to the fact that you payed to have the great customer support. They would have supplied you with an adapter if it was necessary. but it could be from a poor connection to the antenna or your stereo could be less sensitive then the old unit. sometimes a setting on the unit will have an effect on your reception also.
Reply With Quote
  #3  
Old 01-14-2012
Member
 
Join Date: Apr 2010
Location: Canada
Posts: 150
Which unit did you put in? I put a Pioneer Avic x930bt in my truck and found the signal very weak and reinstalled it a / plugged the antenna better and it improved but still not as strong as my stock was.

A week later I added the traffic tuner which plugs inline between the unit and the head unit and my reception improved a lot and exceeds the stock now... unsure if it has something to do with powering the antenna but didn't into it further as my problem was gone with the traffic module installed.
Reply With Quote
  #4  
Old 01-14-2012
Member
Thread Starter
 
Join Date: Oct 2011
Location: connecticut
Posts: 150
crutchfield got back to me its a bad tuner in the unit. they are sending me a new one at no charge. crutchfield rocks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Reverse Signal & Parking Break Signal brainbox General Technical & Electrical 5 06-14-2017 07:24 AM
Head Lights...Turn signal poltergist22 General Technical & Electrical 1 05-09-2015 11:19 AM
turn signal/ wiper unit impact1223 Interior Semi-Tech 5 03-17-2014 12:38 PM
turn signal issues Liftedgreen4x4 General Technical & Electrical 0 08-22-2008 11:27 PM
Head unit Issues psico Audio & Video Tech 1 06-24-2008 06:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:39 AM.