HOLY $H!T - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
Icon9 HOLY $H!T

Ok so i have 2 memphis sr 10s hooked up to a 500watt memphis monoblock....and yesterday i go looking for my headunit remote, and i pull my seat forward and the cone had a hole in it....perfectly cut around the 'M' i could see down to the magnet. The guys at the shop said it was pressure that caused it....i have a 1 year warranty so im gettin a new one popped in...but i seriously think that was the craziest sh!!!!t
Reply With Quote
  #2  
Old 11-15-2010
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
pics or it didnt happen
Reply With Quote
  #3  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
wow very harsh il get em up
Reply With Quote
  #4  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101

Last edited by KLC; 11-15-2010 at 10:07 PM.
Reply With Quote
  #5  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
Reply With Quote
  #6  
Old 11-15-2010
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
Fixed your picture.
Reply With Quote
  #7  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
thanks bro....thats crazy huh
Reply With Quote
  #8  
Old 11-15-2010
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
Looks like it was cut. Good thing for the warranty.
Reply With Quote
  #9  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
noo.....nobodys been in my truck, i guess it just blew
Reply With Quote
  #10  
Old 11-15-2010
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
You using Memphis door speakers too?
Reply With Quote
  #11  
Old 11-15-2010
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
Quote:
Originally Posted by tmilllz View Post
wow very harsh il get em up
I like pics. I was hopin literally a perfect "M" was missing, that would be awesome
Reply With Quote
  #12  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
im running those subs, the memphis 500 monoblock amp, kicker competition mids and tweets, and a pioneer headunit....soon to be doubledin
Reply With Quote
  #13  
Old 11-15-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: visalia ca
Posts: 101
yaah i was looking for the remote, saw that m on the floor and i was like wtf, looked at my sub and shat my pants lol....but glad i got a warranty
Reply With Quote
  #14  
Old 11-16-2010
edge2k's Avatar
Member
iTrader: (2)
 
Join Date: Jun 2010
Location: Daytona Beach, Florida
Posts: 296
Isn't it just a dust cap?

My dust cap came off on a speaker of mine not to long ago, only mine looked like this.
Name:  DSC00229.jpg
Views: 0
Size:  74.2 KB
lol
Reply With Quote
  #15  
Old 11-17-2010
RangOH's Avatar
Member
 
Join Date: Feb 2009
Location: Madison, Ohio
Posts: 854
to the op. it looks like your woofer mechanically bottomed out. It almost seems like the sub was meant to blow out at its mechanical limit. many speakers will just ping off the motor structure till they fail. this looks like its a once and done type deal.

edge2k.. wow that's the worst blown sub Ive ever seen. did you do that on purpose or what? either that or you made one big *** mistake
Reply With Quote
  #16  
Old 11-18-2010
edge2k's Avatar
Member
iTrader: (2)
 
Join Date: Jun 2010
Location: Daytona Beach, Florida
Posts: 296
It was actually pretty much at accidental fault of my own, It was 1 of 12 speakers in an enclosure for a show, that this particular speaker was wired backwards ( i had 6 regular and 6 inverted ) and in the rush didn't catch the mistake, so there was 11 speakers just brutally pushing the opposite way, a super low freq came about and i just heard the worst voice coil sound and it just completely separated the coil from the spider.

After it went and i realized what happened, i just let it flop about for a while before I decided to try and get a replacement.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Holy Crap! My Truck is Something Else with.. BlkTremor02 General Ford Ranger Discussion 28 09-01-2006 09:51 AM
"Holy Icecube Batman, that vent is cold!" Hefavitzen General Technical & Electrical 7 06-15-2006 08:13 PM
Holy crap. i may have to sell some stuff... [email protected] Drivetrain Tech 24 11-01-2005 10:23 PM
holy **** im gonna freak, is my new xs-l101p5 xplod blown!??? hardcoresmylife Audio & Video Tech 39 07-02-2005 12:53 AM
HOLY CRAP - my new system Chodemnky Audio & Video Tech 8 06-07-2005 12:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.