Losing time?!??!?! - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-14-2012
GreaseMonkey01's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2012
Location: Woodbridge, VA
Posts: 304
Losing time?!??!?!

So, I've lost about 30-40 minutes on my clock today, the truck starts and runs, but why is the clock losing time as fast as it is??


Anyone else have or had this problem??? It's just kinda freaking me out....
Reply With Quote
  #2  
Old 05-14-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
twilight zone. run.
Reply With Quote
  #3  
Old 05-14-2012
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Thats odd... The clock must be malfunctioning.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Im losing it! "Monster Truck" Drivetrain Tech 5 12-10-2008 08:28 AM
check engine light flashing and truck losing power..help? Sonic04Edge 2.9L & 3.0L V6 Tech 5 08-17-2008 07:41 PM
Help!!! Losing the Battle With My Shift Knob! bradyj12345 Interior Semi-Tech 21 10-12-2006 06:09 PM
Losing oil, but not burning or dripping... 90RangerZach 2.9L & 3.0L V6 Tech 2 08-11-2005 06:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.