Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Radio losing settings

  #1  
Old 01-03-2019
Member
Thread Starter
Join Date: May 2010
Location: Jackson,NJ
Posts: 35
Radio losing settings

This is the second time I came out to my 08 Ranger in five days and my radio lost its settings. At first I thought it was a one off but just happened when I went out at lunch. The battery is new just put it in back in September. Everything else is fine. Any Ideas?

thanks in advance.
 
  #2  
Old 01-03-2019
cliffdog2004's Avatar
Member
Join Date: Jul 2018
Location: Irvine
Posts: 283
That's annoying, isn't it?

It sounds to me that your constant 12v source may not be constant anymore.

Check your fuses, of course, but here's a list of which wire does what:


The constant 12v source keeps your settings memory intact so you don't have to fudge with station presets, bass, treble, etc.

If it isn't the fuses, you may have to take the dash bezel off and extract the unit to check that Violet/Red wire connection.

Actually simple enough. Two small 7mm bolts at the climate control switches and carefully pull.

Hope this helps.

EDIT***

https://www.autogenius.info/ford-ran...e-box-diagram/

Your fuse box has a few "radio" labels.

#6 , #22, and #24

#24 "sounds" like it may be the one, but check them all.

https://www.autogenius.info/ford-ran...e-box-diagram/

 

Last edited by cliffdog2004; 01-03-2019 at 01:16 PM.
  #3  
Old 01-03-2019
RF Veteran
iTrader: (1)
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 11,838
Did it start happening after the new battery?

If so redo the battery cable connections, clean the cable ends and terminals

What happens is when you start the truck the starter motor draws 70amps and if there is a dirty/loose connection power drops too low and radio loses presets
 
  #4  
Old 01-04-2019
Member
Thread Starter
Join Date: May 2010
Location: Jackson,NJ
Posts: 35
No this did not start when battery was replaced. The issue does not happen when I start it seems to only have happened when truck been sitting for a few hours.
 
  #5  
Old 01-04-2019
Member
Thread Starter
Join Date: May 2010
Location: Jackson,NJ
Posts: 35
I will check it out. Thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Bumpncarstereo
Ranger-Forums Office
7
10-16-2008 11:00 PM
TORQUERULES
4.0L OHV & SOHC V6 Tech
16
05-14-2007 12:25 PM
fletch12518
Suspension Tech
7
08-19-2006 08:29 PM
vansnxtweek
4.0L OHV & SOHC V6 Tech
1
07-19-2006 03:34 AM


Thread Tools
Search this Thread
Quick Reply: Radio losing settings


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.