subs sounding on and off.. - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-01-2010
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Icon2 subs sounding on and off..

I think my RCA cables are done for. Or the unit itself has gone out. Everything works I have power at the sub and wires to the speakers. I think the crappy street wires I bought are shot or the Jensen in-dash has given up. My screen quit working about 2 years after I bought it. No more warranty and looking for another in-dash as we speak.
Reply With Quote
  #2  
Old 04-01-2010
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Try a different set of rca cables.. Ive tested them by using ones you would use for your TV.
Reply With Quote
  #3  
Old 04-01-2010
cheeba17's Avatar
Member
 
Join Date: Jan 2010
Location: stevens point, WI
Posts: 25
one of my friends had that issue too and it ws the rca's so it just might be them
Reply With Quote
  #4  
Old 04-01-2010
vista4.0's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2009
Location: Beaver Falls, PA
Posts: 2,824
check you ground first.
Reply With Quote
  #5  
Old 04-01-2010
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Ground is just fine. I'm going to try the Cables first.
Reply With Quote
  #6  
Old 04-01-2010
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Well I tried the RCA's I had and still no boom. So either the amp inputs or the head unit outputs are done for..
Reply With Quote
  #7  
Old 04-04-2010
99rngr's Avatar
Member
 
Join Date: Dec 2008
Location: Ohio
Posts: 110
Check the power wire? Mine was keep coming loose at the fuse and everytime I'd hit a bump they'd go out.
Reply With Quote
  #8  
Old 04-04-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Prolly your head unit, Kenwoods don't have a great rep
Reply With Quote
  #9  
Old 04-06-2010
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
I have a jensen indash dvd.... screen went out awhile ago.. think it will all just **** here before the end of the year.. haha
Reply With Quote
  #10  
Old 04-06-2010
99rngr's Avatar
Member
 
Join Date: Dec 2008
Location: Ohio
Posts: 110
You could always get a new head unit then and see if it fixes the problem since it sounds like you'll be needing one soon.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
metal squeek reall wicked sounding 01rangerbigfoot Suspension Tech 5 09-04-2007 07:12 PM
looking for a good sounding cat back system 01rangerbigfoot 4.0L OHV & SOHC V6 Tech 26 02-18-2007 02:44 PM
4.0 best sounding exhaust??? whiteo5xlt 4.0L OHV & SOHC V6 Tech 38 01-27-2007 09:06 PM
best sounding quality rock speakers sullys_ranger Audio & Video Tech 24 06-04-2006 12:10 PM
Best Sounding Exhaust 2ranger2 2.9L & 3.0L V6 Tech 19 02-07-2006 07:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.