DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Did I screw up, or what's the secret? (Fuel line connectors)

  #1  
Old 09-23-2018
Member
Thread Starter
Join Date: Jul 2017
Location: Montrose, PA
Posts: 71
Did I screw up, or what's the secret? (Fuel line connectors)

2003 2.3L >225K miles (with P0171)
Just replaced the fuel pump. When I pulled the fuel lines off the pump, I yanked the little clippie things all the way out. Can't seem to get them back into the connector on the end of the fuel line. I tried the old (somewhat deformed) ones. I've tried new ones (Dorman 800-015 or 800-023, I forget). What's the secret? Can't believe this job is held up by a cheap bit of plastic!
 
  #2  
Old 09-23-2018
RF Veteran
iTrader: (1)
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 11,838
No trick, put the clip back in first, then slide the hose onto the fitting, it should just slide on and lock
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Reyn
2.9L & 3.0L V6 Tech
3
11-23-2015 11:00 AM
iplayloudly
Interior, Exterior, Electrical, & Misc.
7
05-02-2012 03:10 PM
FMD
General Technical & Electrical
0
07-11-2009 04:28 PM
buggman
Exterior Semi-Tech
21
02-14-2009 10:15 PM
Lefty04LevelII
Project Logs
39
07-30-2007 04:59 PM


Thread Tools
Search this Thread
Quick Reply: Did I screw up, or what's the secret? (Fuel line connectors)


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.