4x4 Problem 01 ranger 4.0L - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-12-2006
chuck0505's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: roblin, Ontario
Posts: 4
4x4 Problem 01 ranger 4.0L

Hey guys and gals

I have a 2001 Ranger with the 4.0 SOHC. I have recently found out that I have a problem with my 4x4. I decided to perform my usual monthly engage for maintenence resaons (snow yet to fail) when I found out that my 4x4 system has a malfunction. Here is the list of problems, for my on the fly unit.

During start up my Hayes manual says that the 4x4 indicator lights should light up momentarily, they do not light up at all.

When I try to swith the tras case with the switch there is no sounds coming from either the switch, which usually gives me the infamous click-click sound, or the trans case itself.

I have performed the following which did not fix the problem. I have inspected the trans case motor and it is clean as a whistle. I have checked the fuses for the 4x4 unit and they are fine.

I was doing some research on this site and a user had a similar problem with there unit and it was the DRL Module (day time running lights). My DRL Module is in need of replacement aswell as I have no Day time lights. I was wondering if anyone had anyother suggestions for me.

This Truck is basically new as I have not driven it much since I bought it new in 01. I have 64 000 KM on it right now and I only use the 4x4 for inclimate weather.

Any help would be appreciated.
Reply With Quote
  #2  
Old 11-12-2006
jasonsfx4's Avatar
Member
 
Join Date: Nov 2006
Location: weston,wv
Posts: 274
theres some kind of 4x4 relay behind the radio and on my 2000 when it went bad it kicked the 4wd in and out on its own when i had it in 4wd but it could be not working at all so its just not engaging the 4wd. and for the day time running lights module im not sure bc my 2000 and 2003 dont have them
Reply With Quote
  #3  
Old 11-13-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by chuck0505
I was doing some research on this site and a user had a similar problem with there unit and it was the DRL Module (day time running lights). My DRL Module is in need of replacement aswell as I have no Day time lights. I was wondering if anyone had anyother suggestions for me.
I looked at the schematics and couldn't find anything in common (fuses, grounds, etc.) between the DRLs and the 4x4 SOTF system.

Of course, you would want to be sure that all of the fuses, grounds and connectors have been inspected.

The fuses that relate to the 2001 4x4 system are:
5, 9, 10, 11, 28 - Dash box;
13 - Underhood distribution box.

Grounds:
G201 - Under passenger side kick panel;
G204 - Below the dash on top of the trans tunnel near the RCM.

Connectors:
There are connectors right at the T/C motor and at the 4x4 Module, of course. A real troublemaker can be the large 40-pin intermediate connector under the truck directly below the driver seat. It has been known to get water/corrosion inside and is especially susceptible in trucks used in damp climates with road salt. Even if it looks OK now, it's good preventative maintenance to apply some dielectric compound to the pins to help prevent future problems.


If the above turns up nothing, my next stop would be the Ford dealer to see if they could retrieve any trouble codes from the 4x4 module.
Reply With Quote
  #4  
Old 11-13-2006
chuck0505's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: roblin, Ontario
Posts: 4
Thank you very much for the tips I will check those out.
Reply With Quote
  #5  
Old 11-13-2006
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
mine did that too. it turns out that i fried my 4x4 control module and the switch.
Reply With Quote
  #6  
Old 11-14-2006
chuck0505's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: roblin, Ontario
Posts: 4
Well I surely hope I have not fried that cause I can tell ya I would not have to be part of the ranger forum if so, cause I would be shipping this truck out!
I did however purchase a DRL Module and that did not fix the problem so I will be taking it to the dealer.
Reply With Quote
  #7  
Old 11-15-2006
bludmon's Avatar
Member
 
Join Date: Aug 2006
Location: Hartford,Wisconsin
Posts: 6
Quote:
Originally Posted by fddriver02
mine did that too. it turns out that i fried my 4x4 control module and the switch.
Same with mine but I had it replaced while it was still under the 30 day warranty (bought it used at a dealer) they said it was $200 for the module
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger 4x4 problem wark_jason General Technical & Electrical 0 11-27-2011 08:54 AM
2010 ranger 4x4 sport brake problem kevin4b Member Introductions 0 05-15-2011 09:09 AM
99 4x4 ranger (4x4 error) Akuma 2.9L & 3.0L V6 Tech 0 07-14-2010 12:54 AM
02 Ranger 4x4 and 08 F350 4x4 megawattmike Member Introductions 24 10-25-2007 05:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.