Auto trans problem - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-31-2011
Member
Thread Starter
 
Join Date: Jul 2007
Location: NH
Posts: 292
Auto trans problem

I have an intermittent weird problem with my 07 4.0L Auto trans

Truck is sitting at about 43K miles.

At 30K miles I changed the trans fluid and filter. I used Amsoil ATF.
I did overfill it a bit and put a couple hundred miles on it before draining out the over fill. Did change (Aug 2010 might be '09 I can't remember) day before driving from S. NH to Carlisle PA for show. While at Carlisle I drained out the excess.

Weird problem first happened at about 41K miles and again at about 42.5K

What happened is after truck was started I started driving and it would not shift out of 3rd not letting me over 30ish MPH with high revs. Pulled over put in park let sit for about a minute and take off and problem is gone and truck shifts fine. Both times was after it rained out. First time was like 10 minutes after the Springfield MA Tornado (April 2011) while I was in Springfield. Second time was just after a regular rain fall(Aug or Sept 2011) at home.
It has rained and snowed since than and the truck has not had this problem. Tuck has also sat for a week at a time with still no problem.

Any thoughts.

Thanks.
Reply With Quote
  #2  
Old 10-31-2011
Member
 
Join Date: Sep 2011
Location: manchester nh
Posts: 46
i had a similar problem with mine it would also slip when taking off from a stop so i put in that lucas stop slip/leak transmission additive and it went away
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Auto. Trans. Floor Mount Shifter Problem uglymailman General Technical & Electrical 2 06-30-2015 04:31 PM
HELP having major problem with my auto trans hib4x4 Drivetrain Tech 0 02-12-2011 09:29 PM
trans problem on 91 auto venom97 Drivetrain Tech 3 12-18-2008 09:06 AM
'95 2wd 4.0 5-speed engine and trans harness -vs- '97 4wd 4.0 engine and trans harnes lifted97ranger General Technical & Electrical 3 01-23-2008 12:48 PM
auto trans problem: double shifting? Edge of Darkness Drivetrain Tech 7 09-20-2006 11:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:41 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.