Bucking, Lurching, jumping while in drive. - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-30-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: Binghamton, NY
Posts: 9
Bucking, Lurching, jumping while in drive.

Hey Everyone,

I have a 2005 Ford Ranger XLT 4.0 V6 4x4.

It has 112500 miles on it.

Recently while i'm driving down the highway the truck seems to be bucking every now and then. It's most obvious once it's warmed up.

It seems to happen around 45 MPH.

*EDIT* Happens in 2 wheel or 4 wheel drive.
It feels like i'm loosing power and the truck is gripping again for a split second.

This occurs when cruise is on or off.
Straight or banking on a curve.
During this event, there is no decrease in RPM or increase in RPM.
RPM's on tach stay the same.
No check engine lights.

Just before this event started. I had check engine light P0446- Evap System Vent Solenoid. This was replaced.

The bucking problem is still happening.

Any ideas guys? I'm stumped.

Last edited by rboss32; 12-30-2012 at 07:36 PM. Reason: more details.
Reply With Quote
  #2  
Old 12-30-2012
04_xlt_4.0_4x4's Avatar
Member
 
Join Date: Feb 2009
Location: merced, ca
Posts: 1,154
ill follow this one mine does this too
Reply With Quote
  #3  
Old 12-30-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: Binghamton, NY
Posts: 9
Icon4

Quote:
Originally Posted by 04_xlt_4.0_4x4 View Post
ill follow this one mine does this too
How long has yours been doing this?

I'm worried about this, i'm not sure if its something that will just go in the next 250 miles or something.
Reply With Quote
  #4  
Old 12-31-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: Binghamton, NY
Posts: 9
Quote:
Originally Posted by rboss32 View Post
How long has yours been doing this?

I'm worried about this, i'm not sure if its something that will just go in the next 250 miles or something.
Hey guys for any of you having this problem. In my air box there was a fram air filter. It was dirty but not shot. I changed it with a motorcraft air filter, drove about 30 miles and the issue has not happened again yet.

I know the truck had issues before with aftermarket air filters stick to oem and it might solve this. I will update in a few hundred miles.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
popping while in 4 wheel drive littlered General Ford Ranger Discussion 18 10-15-2017 06:19 PM
5R55E is delayed while shifting into drive. HELP!? WISCO-RANGER Drivetrain Tech 0 04-10-2014 09:24 AM
No drive to my front wheels while under load and making a grinding noise jmccracken91 Drivetrain Tech 0 06-24-2013 02:52 AM
rough idle, gas smell, lurching at stops kristen 4.0L OHV & SOHC V6 Tech 18 01-05-2012 06:13 AM
steering is jumping around a bit. what is it wdstone Suspension Tech 5 06-11-2005 06:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.