M5OD no clutch - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-29-2010
Member
Thread Starter
 
Join Date: Sep 2010
Location: houston,tx
Posts: 2
M5OD no clutch

1988 ranger 2.0 m5od

I removed the m5od,clutch and flywheel to get to the rear freeze plug (leaking). Put in the .75 cent freeze plug and put everything back together and NO CLUTCH. Ignition off , the m5od shifts through gears fine. Crank the vehicle and push the clutch, won't go into any gear. I put it into 1st ,push the clutch, and crank the vehicle and it jumps forward. The clutch is not engaging. It was all working fine before I tore it down (except the leak). I could not get the clutch hydraulic cable loose, so I removed everything from the firewall and dragged it out with the m50d. Do I need to bleed the system ?(What is best way to do it in truck) Don't even mention a slave fail.
Reply With Quote
  #2  
Old 09-29-2010
Member
 
Join Date: Aug 2010
Location: Welland, ON
Posts: 186
pull your inspection plug and see if the slave is leaking.
you need to bleed the master though. I put a new slave in mine and i gravity bled it. that did virtually nothing. lol so I pulled the master and bench bled it like the youtube video shows to do. i could push the rod in and hear the squishy air, then i tapped the master with the screw driver and i could see bubbles floating up into the reservoir. Just remember to keep the master`s tube ends upward (aka not the way it is in the truck which seems to be designed to hold air lol).

then i put it back in and it was literally the best i have felt the clutch in my ranger ever (only owned it while it was hard to shift lol)
Reply With Quote
  #3  
Old 10-11-2010
Member
Thread Starter
 
Join Date: Sep 2010
Location: houston,tx
Posts: 2
SUCCESS!! I bled the slave and nothing. But I thought maybe it's just stuck? Put it in 2nd, pushed the clutch, cranked the engine and BAM! Not a lurch, but a loud THUNK! and clutch came loose. Drove it around the neighborhood with a smile. Now I got a oil leak somewhere, it's always something
Reply With Quote
  #4  
Old 10-11-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Get back under there a double check the bolts holding the pressure plate to the flywheel.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
M5OD Transmission Top Cover Okay to Remove? CaliGold Drivetrain Tech 4 01-18-2014 05:41 PM
3.0L M5OD-R1 problems. Transmission or clutch?? USMCWHITENER Drivetrain Tech 1 05-03-2012 02:32 PM
Toyo Koygo to M5OD-R1 swap clutch and flywheel question pbilt Drivetrain Tech 0 03-04-2011 10:37 PM
M5OD-R1 vs M5OD-R1HD whippersnapper02 Drivetrain Tech 9 01-09-2008 11:11 PM
Metal shavings in M5OD ks ranger Drivetrain Tech 9 06-26-2007 02:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.