need help on 93 3.0 5spd. - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-04-2009
USMCWHITENER's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2006
Location: Sharpsburg, GA
Posts: 241
need help on 93 3.0 5spd.

So i bought a 1993 Ranger with 3.0L V6 with 5spd...engine needed to be replaced so i pulled it and bought another engine from buddy....put engine back in and installed new perfection clutch because my bro works at Advance Auto Parts...well put it all back together..bought a new clutch slave cylinder also....but put it back to gether and tried to bleed the clutch...can't get resistance on clutch...so went last night and bought new clutch master cylinder with new resevoiur...tried to bleed it today....still have the same problem...can anyone guide me in what i need to do now??? I'm getting fluid out of the bleed valve on slave cylinder...just cant get pressure and resistance on clutch...any help is very much appreciated. Thank You in advance!!!

USMC WHITENER
Reply With Quote
  #2  
Old 04-04-2009
wvcat's Avatar
Member
iTrader: (4)
 
Join Date: May 2007
Location: New Cumberland
Posts: 2,044
You probably have an air lock in the clutch master cylinder. You will have to remove it from the firewall and point the line end up so gravity bleeding can force the air out then reinstall
Reply With Quote
  #3  
Old 04-04-2009
USMCWHITENER's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2006
Location: Sharpsburg, GA
Posts: 241
i think i know what your saying wvcat...but it was the same way on the old master cylinder....i just assumed the old one had gone out..so bought new one and still does same thing...you think there may be an air lock on it though??? I'll take it back off and see what i can do. i'll let you know if there is any difference. Thanks
Reply With Quote
  #4  
Old 04-05-2009
USMCWHITENER's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2006
Location: Sharpsburg, GA
Posts: 241
ok took the master cylinder back out of the truck...did what was said and still cant get anything...any other ideas??? hopefully its not the slave cylinder itself...could have been a defected part off the shelf....
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
need a 1998 2.5L 4cyl, 5spd aluminum oil pan Uminneapolis SOHC - 2.3L & 2.5L Lima Engines 1 09-03-2013 07:33 PM
need some info on 5spd transmissions USMCWHITENER Drivetrain Tech 1 04-18-2011 08:13 AM
Want to Buy: NEED 2.3 5spd reg cab trans x-member!!!!! MI 93mk8 Engine & Drivetrain 0 06-01-2010 09:12 PM
socal HELP! 3.0 5spd 4x2 broken j_reagan Drivetrain Tech 0 04-13-2010 02:04 AM
Help with 94 4.0 5spd eclipsewelder 4.0L OHV & SOHC V6 Tech 2 04-02-2009 12:31 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.