New guy with a clutch question I thought I knew - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-06-2011
Member
Thread Starter
 
Join Date: Mar 2011
Location: Coarsegold, CA
Posts: 4
New guy with a clutch question I thought I knew

My old 83 2.8 V6 just developed a new for me problem. It was fine one night,next morning would not disengage. Pedal felt just like normal, so I figured it was a cylinder problem. I had the new spares so I replaced both the master/slave. Bled them right like all the others I had done, pedal felt like normal, no play, no spongy air feel, nice and solid. But still no disengage. If I put it in gear, and start it up it will run, but really drags so it is partially working. Could it be the release fork has bent? Thanks for any ideas.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Who knew the Canadians Did so much btm757 General Ford Ranger Discussion 27 02-14-2010 07:49 PM
We all knew it was coming........ Rolldogg General Ford Ranger Discussion 35 01-22-2008 10:51 AM
knew way to remove rust 05edge General Ford Ranger Discussion 7 07-07-2007 01:21 AM
Never knew how by my clutch was until... fx4me General Ford Ranger Discussion 26 03-28-2006 04:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:59 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.