Possible Clutch Problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-02-2009
Member
Thread Starter
 
Join Date: Jul 2009
Location: St. Louis
Posts: 20
Possible Clutch Problems

I recently replaced the transmission in a 1992 6 cylinder. Thanks for all the help from the forum. My son came back in town and has a issue with the clutch pedal.I think this has been like this since we changed it. Should the clutch pedal have a little play in the pedal?This one doesn't really.It makes a small noise like the clutch plates might be touching. I was thinking it might have air in it or to much fluid? Would like to know if this is a potential problem? I posted in another topic and nobody would answer. I do not want to wear down the clutch prematurely. Thanks.
Reply With Quote
  #2  
Old 11-03-2009
My91Ranger's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2007
Location: Roseville, Michigan
Posts: 2,252
Sounds to me like the slave cylinder may not be bled well enough yet. I had a hell of a time doing it on my 91 ranger. I found a technique I believe on autozones repair site a couple of years ago where you would slowly depress the pedal by hand and let it swing up hard several times and it would help purge the system of the air. I dont' think thats all the instructions but I know it worked great for me at the time. You could even see the bubbles coming up into the fluid reservoir.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Possible clutch issue? pearlkid9988 Drivetrain Tech 6 02-12-2014 10:15 PM
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
New Member - Wrong Clutch! Possible to put 4.0L v6 clutch on 2.3 4cyl w/ new flywheel DJDev Drivetrain Tech 2 10-28-2012 09:41 PM
Possible Clutch Problem. Any Ideas? susieranger General Ford Ranger Discussion 3 09-09-2011 05:43 AM
Need help. possible clutch issue? edgeman4.0 Drivetrain Tech 8 01-18-2009 06:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.