Thumping/jolting when accelerating immediatly after slowing for a turn or a red light - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-25-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: Murrieta
Posts: 2
Thumping/jolting when accelerating immediatly after slowing for a turn or a red light

Hi, Recently I've noticed that if I slow down for a turn, then accelerate again after the turn, my transmission (or so I think) slams into gear. Also, if I go from reverse to drive quickly and accelerate, it shudders and slams into gear. In addition, when I am on the freeway, going maybe 60 and I want to go up to 70, I have to push really far on the gas pedal, almost flooring it, before my truck will react, I would think it should start to rev up immediately. After about a second or two, it suddenly downshifts then revs up like it should.
Reply With Quote
  #2  
Old 07-26-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,617
You should have the 5R55E automatic trans in the '07 with 4.0l SOHC

Common failure in these is the separator plate.
To test if this is the problem put trans in 1st gear drive up to 15-20mph then let off the gas, trans should not disengage you should slow down with engine RPMs, if you coast then separator plate has a failed gasket section.

It reads like this could be the issue since trans is disengaging when slowing then re-engaging, with a delay, when accelerating.

There are a few "how-tos", if you google it, on replacing the 5R55E separator plate with trans in vehicle, I have never done it, I did read that you should buy the separator plate from Ford, under $20, as it has the gaskets bonded to it which can prevent future failure.

Automatics are tough to diagnose on a forum, lol, so grain of salt.

Last edited by RonD; 07-26-2014 at 11:19 AM.
Reply With Quote
  #3  
Old 07-26-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: Murrieta
Posts: 2
Hi, and thanks for the reply. I did as you said and the transmission did not disengage, so I don't think that's it. I forgot to mention that this truck has larger tires on it than it came with and thus the speedo is off by ~5mph. It feels to me like its having a hard time switching between maybe 3rd and back to 1st (idk) since it usually happens when I'm doing around 40mph and I slow to 10-15mph for the turn. Same thing when I slow down for a red light then it turns green and I accelerate again.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 4x4, rough idle, stutters while accelerating or slowing down, smooth at 2500 rpm likemytruck 4.0L OHV & SOHC V6 Tech 1 06-01-2015 09:39 PM
2000 Ranger V6, jerking when accelerating after shifting watsont5 General Ford Ranger Discussion 2 12-18-2014 02:00 PM
please help immediatly, no spark = no strat 894banger SOHC - 2.3L & 2.5L Lima Engines 5 04-15-2011 05:06 PM
clunking and jolting jamesxEDGE Suspension Tech 9 10-28-2008 01:30 AM
Slowing down LED bulbs in the turn signals Mnemonic General Technical & Electrical 5 06-12-2004 08:12 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.