Nightmare ranger with GEM fuse short - Ranger-Forums - The Ultimate Ford Ranger Resource


Exterior Semi-Tech General discussion of exterior for the Ford Ranger.
Sponsored by:
Sponsored by:

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-10-2015
Member
Thread Starter
 
Join Date: Jul 2015
Location: San Diego, CA
Posts: 2
Nightmare ranger with GEM fuse short

hello all. I am new to this site and sorry to beat up the topic but My dad has an 2001 ranger 3.0 M/t, no p/w and p/l. He installed a new battery in his truck and all of a sudden not interior lights, wipers and speedo. He took his truck to a mechanic and they told him he needs a new GEM module. It also blows the 10 amp GEM fuse every time seeing there is a short. So I got a used one with same part number and installed it.... Same problem. Today I removed the speedo, dimmer switch, pulled all of the dome lights out and battery saver relay and still the fuse blows. If someone can please help steer me in the right direction I would greatly appreciate it. Just becoming a nightmare.
Reply With Quote
  #2  
Old 07-10-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,582
That would be fuse 26 correct?

PITA problem if it is.

This 26 fuse is "hot all the time", so does it blow when you put in a new one or does it blow only when you turn on the key?

First open the hood and check wiring near ANY exhaust parts, especially EGR tube, look near the battery for possible wire issues, since after battery change this started.

near the cab fuse panel there should also be a relay panel, or it may be behind radio with GEM, check the wires on the relays I have seen them melt together.

Also Google: Ford Ranger fuse 26 blowing GEM

There is no one answer unfortunately.
Reply With Quote
  #3  
Old 07-11-2015
Member
Thread Starter
 
Join Date: Jul 2015
Location: San Diego, CA
Posts: 2
Headache.

Yes it's fuse 26. It blows the fuse at any time except when battery is disconnected of course. I have checked engine compartment. I had the dash appart looking for wires back behind the speedo and radio where the GEM mod. Is. I switched and eliminated relays in the #1 relay box up underneath the dash. With battery saver relay out, it doesn't blow the fuse until you turn the dome light on. I am guessing I has to be the dome light wire is shorter somewhere but why just after a battery install? This is the third battery replacement over the life of the truck. I don't really feel like tearing the whole interior apart to look for this problem and may not even find it
Reply With Quote
  #4  
Old 07-11-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,582
I don't envy you your task

These are wiring diagrams for 2001 Ranger with 3.0l
Wire colors might help, OHM meter to test for shorts would also be handy
Attached Files
File Type: pdf 2001-GEM.pdf (38.8 KB, 126 views)
File Type: pdf 2001-interior-light.pdf (39.5 KB, 56 views)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger short box vs S-10 Short box (Dimensions) 20102wdRanger General Ford Ranger Discussion 8 01-19-2013 10:32 AM
Fuse #26 resets GEM after being idle ggreen24502 General Technical & Electrical 3 06-07-2012 08:02 PM
Keep Blowing my Radio/GEM fuse INT3RC3PTOR General Technical & Electrical 8 03-24-2009 07:18 PM
3M rubbing compound residue nightmare FMD Auto Detailing 101 24 01-13-2006 12:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.