1994 2.3 Ranger (manual) intermittent SERIOUS lack of power - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-08-2015
Member
Thread Starter
 
Join Date: Nov 2015
Location: Prospect, CT
Posts: 2
1994 2.3 Ranger (manual) intermittent SERIOUS lack of power

My uncle has a 94 Ranger, 2.3, manual, about 200K on it, and is dealing with an intermittent SERIOUS lack of power/ rough idle. Most of the time when he starts it up it's running poorly and has that lack of power (barely makes it up hills, top speed of maybe 20MPH). Sometimes the truck just starts running like there is nothing wrong with it at all. He replaced the plugs, wires, dual coil packs, fuel filter. There is no check engine light on but when I used the old EEC code reader I got code 335 which is EGR (PFE) sensor voltage out of range. That wouldn't cause a SERIOUS lack of power (intermittently), would it? Is there anyway to test this? Please shine some of that mighty intellect I see on this board and tell me what YOU would do if dealing with this problem. Thanks in advance,


Dan
Reply With Quote
  #2  
Old 11-11-2015
Member
 
Join Date: Nov 2010
Location: tampa fl
Posts: 14
yeah... that happened to me one time. could not keep highway speed in 5th. only in 3rd... never figured it out and never happened again.
Reply With Quote
  #3  
Old 11-11-2015
Member
Thread Starter
 
Join Date: Nov 2015
Location: Prospect, CT
Posts: 2
This is an ongoing problem though. When he starts the truck it's close to useless. After maybe 20 minutes it kicks in and it literally drives wonderfully. Then it will return to almost useless. ANybody have any suggestions? I'm going crazy trying to figure this out.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Lack of power. 2.3 5 speed Poorboy316 SOHC - 2.3L & 2.5L Lima Engines 9 08-05-2014 05:08 PM
lack of power, almost stalls zak873 General Technical & Electrical 2 10-02-2011 10:22 PM
93 2.3 lack of power/poor idle carbuff1991 SOHC - 2.3L & 2.5L Lima Engines 1 04-28-2009 09:36 AM
lack of power in 3.0 jacarter87413 2.9L & 3.0L V6 Tech 7 01-30-2008 09:56 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:07 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.