4x4 lights flashing after stereo install - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-18-2016
Member
Thread Starter
 
Join Date: Sep 2015
Location: Mo
Posts: 5
4x4 lights flashing after stereo install

So I had a shop remove an aftermarket stereo and install a new one today. Now when I start the truck 4x4 hi/lo flash 6 times and repeats after about 3 minutes.. They said they didn't touch the switch wires or the 4x4.. I tried checking for power at the switch wires, nothing, tried disconnecting the harness from transfer case and checking for voltage, nothing.. what the hell is going on? How can a stereo install go to a 4x4 failure.. I find it hard to believe something went out magically between me driving from the parking lot to their garage. Any advice would help
Reply With Quote
  #2  
Old 06-19-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,577
1998 will have a 4x4 module behind the radio, it is basically just two relays in a box, maybe they moved or pushed on wires and it has loose connection now.

GEM(generic electronic module) is also behind the radio and is also part of the 4x4 system, this controls the 4x4 module and the dash switch, so GEM is flashing the 4WD light, because something is unhooked or broken.
GEM controls inside lights, wipers, door locks, 4WD, ect.............so it is fine if all you have is flashing 4WD light.

Pretty easy to push in a radio and unhook a connector, my guess would be thats the problem.

1998 4WD control diagram below
Attached Files
File Type: pdf 98 4WD shift control.pdf (56.6 KB, 17 views)
Reply With Quote
  #3  
Old 06-19-2016
Member
Thread Starter
 
Join Date: Sep 2015
Location: Mo
Posts: 5
Ok, I'll do a little more digging in the dash, hopefully it's just something loose
Reply With Quote
  #4  
Old 06-19-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,577
Fuses to check

#3 in engine compartment fuse box

#9, 26, and 27 in cab fuse box

Any of these could have been blown by "radio work" and if blown would cause flashing 4x4 lights
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Stereo, Stereo components, install stuff SteelDirigible Interior, Exterior, Electrical, & Misc. 0 09-07-2014 12:39 PM
flashing 4x4 lights 1959ranger General Technical & Electrical 2 08-19-2013 04:45 PM
4x4 lights flashing bdwilsonjr Drivetrain Tech 3 07-05-2010 04:07 PM
4x4 HI & 4x4 LOW lights flashing Wolf08 Drivetrain Tech 3 06-05-2009 08:26 PM
4x4 lights flashing, no lock up Hitch Drivetrain Tech 5 11-12-2006 09:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.