93 2.3 slow crank but wont start...? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Closed Thread
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-13-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: akron, oh
Posts: 5
93 2.3 slow crank but wont start...?

i have a 93 ranger 2.3 5sp 170k it will crank slowly but not start. i started it one morning and by the time i came back outside to goto work it was shut off and wouldnt start back up... it has spark and is getting fuel ive tried to jump it still nothing.... ive replaced the clutch safety ignition switch and also a coil pack... battery was bench tested also.
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
93 2.3 slow crank but wont start...? michaels813 SOHC - 2.3L & 2.5L Lima Engines 5 02-24-2011 11:11 PM
93 2.3 slow crank but wont start...? michaels813 General Technical & Electrical 0 02-13-2011 07:14 PM
RangerNDog's Slow Slow Build RangerNDog Project Logs 25 09-10-2009 04:18 AM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 11:35 AM
The 3.Slow? More like my 2.9 extreme slow phreaky728 2.9L & 3.0L V6 Tech 7 03-20-2005 05:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.